All front lights flashing - Cause?


I’ve been running my 5N for 2 years, or to be precise 2 years and 1 week, and by and large everything has been going fine.

I came down to the office a few days ago and my 5N is having it’s own little disco party. Every single LED on the front panel is flashing in sync - drive lights, capacity gauge, access light, power light - everything. I later checked the green LED on the power supply and even that has joined in.

Drobo very kindly sent me out a new power supply which arrived today, but when I connected it the same thing happened, right down to the LED on the power supply flashing.

I have tried a new mains power cord and also tried connecting the power supply to a different socket on a different ring main, but the same thing happens.

Does anyone have any ideas or experience that can help?


We can confirm that is not a PSU power issue since a new PSU was used.

What you can do is to test and check if it is a enclosure issue. If it is and is covered by warranty… you can contact Drobo Support and get a replacement unit.

  1. Power OFF the Drobo 5N.
  2. Make sure the 5N has no power to it, and remove all the drives.
  3. Now power ON and boot the Drobo 5N without drives.

The correct boot sequence without drive should be:

  • All drive bays light up Red or Yellow then disappear.
  • Next, the capacity blue light will light up one by one from the left to right until it reaches the 10th blue led light…
  • Finally, the Top Most empty drive bay will light up RED (Solid RED).
  • Dashboard should be detecting the 5N and prompt that there is no drives … please insert drive etc… which is indicated by the RED light on the Top Most drive bay.

**Important - Do NOT insert your existing 5N drives into the unit while is powered ON. Inserting drives into a powered ON Drobo will result in formatting the drives… causing data lost.

If Drobo 5N WITHOUT drives, cannot boot up properly as above mentioned. That means it likely to be a faulty hardware enclosure.

For example:
Drobo 5N without drives, boot up:
a) All drive bays stuck at RED or YELLOW
b) Rebooting loop
c) All lights (Drive Bays, Capacity Blue Light etc) all blinking…

The above is like to be a hardware issue…

To re-insert existing drives back into the 5N…

  • Power Down the empty Drobo 5N. Make sure is powered off completely.
  • Insert all drives back into the drive bays… make sure they seat properly.
  • Power Up the Drobo 5N with drives…

hi, just a quick question on the psu…
you might have already done this, though did you actually completely use all parts of the new psu?

it usually comes in at least 2 parts and i remember trying just 1 part at a time when one of mine failed, to see which piece was having the problem. (just in case you only tried 1 new part and still the faulty other part)?

Thanks for the tip Paul, but I used a new mains lead as well as the power supply and even tried a using different mains socket just to ensure the fault was with the unit.

Looks like it’s a swap out job.

ok thanks for clarifying about the psu,
and if you got similar feelings from trying dons suggestions then yes that might be the case.

I just wanted to thank both Paul & Don for their help.

Don, after the checks you suggested it was very apparent that it was a fault with the enclosure. A replacement unit has now arrived and is currently doing a few weeks worth of Time Machine backups.

I also wanted to thank Nadine especially from the Drobo care team for her help in getting the replacement sorted.

cool nice one :slight_smile:

(you mentioned a Nadine, ive had some cases with a Sabine, so im guessing somewhere within drobo support, there must be a Sandrine) :smiley:

Hi Bluemoonin65,

Great to hear that you managed to have the fault Drobo replaced. :slight_smile: