After firmware update, shares are inaccessible, can't login to Drobo Dashboard

I’ll keep this brief because I’m in disaster recovery mode and this post is really just a “Hail Mary” moment-

I ran a firmware update on one of our 5n2 devices, to the latest firmware version (4.2.2-x) and now the file shares are inaccessible, I can’t stay logged in to the devices as a successful login just immediately logs back out, and I have the constant error in the dashboard “Error while setting up Domain Configuration. Please contact support.”

The device is apparently no longer eligible for DroboCare extended support, and I can’t reach anyone via because I don’t have a ticket number in the subject of the emails to them, because I can’t create a ticket because it is no longer under warranty.

This is the kind if thing that sours a person on a brand.

The 5n2 in question is being overnight shipped to me, from the particular location of ours that was using it, and I’ll be trying my hand at getting data from its disks on Friday, but I hope someone here can provide some much needed assistance between now and then.

Thanks in advance.

Not sure what to tell you but join the drobo user group on Facebook. A lot of people there who know a lot… just like here, but no harm in doubling your chances on getting closer to a solution. Sorry I cannot help with that

emailing tech-support will not reach support. You will need to go to > Support > Support Portal to create a support case.

I can’t create a support case because my particular device is no longer under any kind of warranty.

I’ve had a similar issue after performing a firmware upgrade on my 5N2. The solution for me was to perform a pinhole reset, with the drives removed, then re-inserting the drives.

Here are some instructions on how to perform the pinhole reset (the ones in the documentation don’t really work):

So, here’s the complete procedure I followed:

  1. Power down Drobo
  2. Remove all drives
  3. Unplug the power brick
  4. Press the pinhole button in the back of the unit (and keep pressing it until the process is complete)
  5. Press the power switch (and keep pressing it until the process is complete)
  6. Wait until the lights come on
  7. Then, with no drives, try to apply the latest firmware (as of today, 4.3.1 → start drobo 5n2 - Drobo)
  8. Once the firmware upgrade is complete, power down Drobo
  9. Insert all drives while Drobo is off
  10. Boot up Drobo

Do not perform the pinhole reset with the drives in, or you may lose all your data. Also, the pinhole reset might require you to reinstall any DroboApps.

I hope that works out for you!




Today I applied the latest firmware update to my previously reliable Drobo 5N2 and it exhibited the following behavior:

  • Firmware upgrade using latest version of Drobo Dashboard went smoothly through initial steps
  • Drobo Dashboard downloaded the new firmware and applied it, and prompted the user to restart the Drobo in order for the new firmware to take effect
  • Upon restarting the Drobo 5N2, the 5N2 briefly powered up and displayed all LEDs and then completely shut down within 1-2 sec
  • This behavior is repeatable. The 5N2 never completes the boot process. It simply shuts down almost immediately

I carefully removed all hard drives to protect them and tried to start the Drobo 5N2 without any drives in the device. The same behavior without any observable change is observed

This 5N2 device and power brick has always been protected by a UPS with filtered surge protection. The timing of this problem relative to today’s attempt at a firmware upgrade, especially given what appear to be two other similar recent reports, suggest to me that I am experiencing the same issue and it was triggered by the firmware.

I have submitted a formal support request via the Portal (my Drobo products are registered).

Thank you @dom1 for posting about the pinhole reset procedure. I will likely be attempting to recover my 5N2 this way soon


As a follow-up to my problem report, here is the successful resolution:

  1. I was able to confirm that the power brick was not the problem by swapping out the power brick from a compatible 5N unit. The same failure mode (immediate shutoff after power up) was observed.

  2. I tried many attempts at the pinhole reset procedure, but no attempts caused any change in the failure mode.

  3. After relaying this information to Drobo Support, Drobo agreed to replace my unit under RMA. This was despite my unit no longer being under warranty.

  4. The replacement unit arrived within about one week of my shipping them the failed unit. I followed their standard disk migration procedure carefully and was back online in a few hours. All data and settings from original 5N2 migrated to the new chassis.

Kudos to Drobo for taking care of this long time customer!

I started a tech support case with Drobo regarding this same issue but got no response other than the automated message. How long is a normal response time?


Were you able to resolve this issue?




I have a similar issue w/ an older 810N. Were you ever able to resolve the problem?



The fix for us was to:

  1. Power down the B810N
  2. Pop the drives
  3. Reboot
  4. Upgrade to 4.3.0
  5. Turn off LDAP / AD auth