Drobo

AFP shares still blank. removed .AppleDB etc HELP!!!

Well it’s been 2 months and my Drobo FS is a door stop. I’ve removed the AppleDB from my time machine share, but the share still won’t mount with anything in it and will hard crash my computer etc. At this point. Drobo said just copy the data to a new share. Problem? I have 3.4TB and only 5.8TB of space. So it’s impossible to do a copy/move. The data is just too big.

HELP I need my backup working. I have read and done all the KB articles except move since I don’t have enough space to do so. Drobo if you want to fix this problem for me. Send me a brand new 2TB Western Digital Caviar Black 2TB so I can add the space I need to move all my files. I have 4x2TB WD drives+500GB Drive, but refuse to buy another drive due to Drobo not fixing the mess they caused and also I don’t have the money to buy the drive.

PLEASE HELP!!!

Have you tried creating a new share and then moving the data via a shell session? That way you can move it straight to a new share without temp space, copying, etc.

mv Shares/MyOldTimeMachine/*.sparsebundle Shares/MyNewTimeMachine/

I tried that using the mv command but it still did a a copy and couldn’t complete. suggestions for exact command?

Old share Time-Machine-Old
New share Time-Machine

do I need them mounted via drobo or finder to do the command? I had them mounted last time.

You’d have to do this via SSH while logged in directly to the Drobo (which requires either the dropbear DroboApp or ricardo’s OpenSSH DroboApp). If you mount the shares elsewhere (Finder, Windows Explorer, etc) then they’re rightly viewed as two separate filesystems. Only the DroboFS knows the truth that they’re all stored on one filesystem and just shared separately, which is why you have to be logged into the DroboFS via SSH to pull this off.

Personally, I wish there was some simple interface in Drobo Dashboard to move the contents of one share to another, without requiring an SSH login. That would be something that would justify Dashboard’s existence.

I was logged in via SSH with Drobo on the phone. I will try it again with everything un-mounted and then do the command via SSH and hope for the best.

I know that it works; I’ve done it before and from the DroboFS’s perspective it’s all one filesystem. It may churn a lot as I don’t know if this will ruffle the feathers of BeyondRaid, but it certainly won’t make a copy of the data.

It worked, I deleted the old share, but now it just crashes my computer when I try to mount the new share. GRRR (I left it for 3 hours with the spinning connecting in the finder window).

That is incredibly odd. I can’t figure out why the mere presence of a file would cause it to go bonkers. So if you move the file out, it mounts fine, and moving the file back in makes it go screwy?

Anything console log activity when it happens? I’m just about out of ideas.

I already deleted the old share. The sparse bundle is on the new share now and it’s the only share. Next step? Call Drobo?

Although I wouldn’t do this long term, you can always move the file below where the Shares are (mv ~/Shares/*.sparsebundle ~/) just to see if the share mounts again.

Huh, now there’s an idea - if you move it and it mounts properly (and you can do basic things like create a folder, move a couple small files to it, etc), what happens if you move the sparsebundle back to the share while it’s mounted?

I think I will direct connect to my MDD G4 2003 and it be the torture device, so I can leave my 2007 2.66GHZ Mac Pro at peace.

Well I moved the sparse bundle to shares and the share mounted, moved the sparse bundle back (didn’t dismount share) kernel panicked and now spinning ball. I critically need files from that backup so no way can I delete it.

HELP!!!

If you critically need those files, can you move the sparsebundle back where it belongs, mount the share via SMB rather than AFP, and mount the sparseimage on your desktop? That should work, and you can then (slowly) navigate the folders to find the files you need.

But something is indeed very, very wrong that it can KP a machine just by moving the file into view.

It was mounted when I moved it.

I deleted the old Time-Machine share. I am going to try and create a new share (don’t mount it) and move the file there, then mount it.

New share same issue, spinning circle. Finder crashes forced to restart Mac (hard reboot).

Spoke to Drobo they are at a loss as to what to do. Now I am waiting for a senior tech to call. I Have done everything in there KB articles.

Have you tried downgrading the fw to 1.1.1? You may then need to repair the file system. I had similar problems with Lion and 1.2.0. I had 3TB’s of stuff that I thought I had lost. Ran out and bought another NAS and copied via smb from that NAS the data on the Drobo FS. I had tried many of the things you had tried previously and this was a final last attempt. It worked. I then reset the Drobo and all is working great again, except for Time Machine. Will wait for Drobo to upgrade from fw 1.2 before even moving from 1.1. I am back to 35 Mb/s with my Drobo using 1.1.1 compared to less than 35 kb/s with 1.2 ( using AFP). It’s all a mystery to me at least.

Philip

Don’t have the money for another HD let alone another NAS.