Adding 5th drive -- Flashing red light

I have a Drobo FS that I have been using for a long time with 4 drives. I want to add a fifth drive, but when I put it in the slot, the light flashed red. Drobo dashboard reports it as a failed drive.

I know that the drive is good as I can plug it directly into my computer and it works fine.

Am I doing something wrong?

it might be that the new drive you tried, needs a newer firmware, but its also possible that it had some errors that the drobo detected that other tools might not have found.

am not sure yet but would you be able to post back when you can with some more details about the 4 drives you are using, and the 5th one you wanted to use?

eg make, size etc,

I’m curious is the Drobo reported it failed instantly or after some time… I have a 2tb drive thst my FS failed after some time and when I tried to put it into my Drobo S, the S instantly refused it… as if the FS wrote something on the drive to mark it failed… either that or something in the Smart data is bad enough to instantly trip the failed flag… as a side note, i reformatted the drive and Stablebit scanner has given it a fully clean bill of health…