Drobo

Accessing the Drobo through an access point?

I am not that familiar with how to setup networks, but I do have a router that acts as an access point and gives devices connected to it IPs that look along the lines of 192.168.3.1, the important part being the 3 ofcourse. Now my Drobo is connected directly to my main router which gives IP’s such as 192.168.1.1, when connected to the access point I cannot see the drobo device under the network section in windows but when I connect through my main router I can see it fine. Is there a way to be able to see it through the access point aswell?

Does it work on the access point if you assign a static ip with 192.168.3.X?

Yes, but it depends on your access point. You have to configure it to behave like a bridge instead of an access point.

Check the AP’s manual to see it this is possible.

Yeah I just checked, nothing about a bridge mode so I assume my access point doesn’t support it. Oh well guess I have to resort for wired connections for now. Thanks trying btw, to the both of ya.

Well, there is one last possibility: you could try to add a manual static route on your AP for the subnet 192.168.1.xxx.

In other words, teach it manually how to forward packets from the 192.168.3.xxx subnet to the 192.168.1.xxx subnet.

It is a long shot, but maybe it’ll work. (Again depends on whether or not your AP supports that)

@mobious: Do you need two different subnets, or is it just that you’re just using the router+AP strictly as an access point?

If you’re just using the router+AP as an access point to provide wireless network access:

  1. Give your router+AP a static internal IP in the same subnet as your primary router (ie, make it 192.168.1.2)
  2. Set the Gateway address on your router+AP to your primary router’s address (192.168.1.x)
  3. Turn off DHCP server on your router+AP
  4. Connect the LAN port from your primary router to a LAN port of your router+AP.

Unless your router+AP separates the LAN and WLAN traffic (most don’t, and those that can usually default to not), this will bridge your WLAN to the router+AP’s LAN, which is connected to your primary router’s LAN. Wireless clients will get a gateway address of the primary router, so the packets will go to the router+AP, then through its LAN to the primary router and wherever it needs to go from there.

This technique may not work for all routers, but I’ve used it successfully on Linksys WRT54G router+APs with stock firmware.

EDIT: Thanks to j_hah for reminding me that the DHCP server on the secondary router should be disabled. :slight_smile:

Is there some particular reason that you are using this setup with two different DHCP servers on different ip ranges? Also, what type/brand/model of access point are you using? If your access point is a router and access point, which network port on your access point is connected to your router?

If this is your home network and you don’t have a particular reason for this setup, then it would probably be easier for you if you turn off DHCP on your access point and use it in bridged mode with your current router so that everything is on your routers 192.168.1.x network. If your access point is a router and access point, try turning off DHCP and connecting your AP to your router using the LAN port instead of the WAN port. If your access point only has a single port, then look in it’s admin console to set it to run in “bridged” mode.

Provide more specific details on both your router and access point and it will be easier to walk you through your specific setup. [hr]

I wouldn’t expect this to work. If you put a static 192.168.3.X address and plug this into your router’s 192.168.1.X network, you most likely won’t see your Drobo FS from either network with your current setup.

I honestly have no clue why its setup that way, like I said I am unfamiliar with how these things are setup so I have a guy that does that sort of thing for me. Anyways Bhiga you saved the day once more! Your steps did the charm, you see I did exactly as you said the first time, but I didn’t know I had to connect the Ethernet cable on the LAN port instead of the WAN. now its working like a charm!

Glad it worked. I had to set up a relative’s system like this because they got a new modem+router combo from their ISP, and the wireless router didn’t like getting private IPs on its WAN port.

After a mass-unplugging session, my relatives called me again because it wasn’t working correctly. They had plugged it into the WAN port by mistake.

So the next time I was over there, I put tape over the WAN port. No more calls since. :slight_smile: