Drobo

Accessing Referenced Master on DROBO FS using Aperture 3.1

I’m not sure what forum to put this in, so I’ll try here since the Aperture forum has no posts. I just purchased a DROBO FS which is connected to my MBP through a gigabit switch. After doing my most of my editing with the referenced files on my MBP, I relocated the masters to my DROBO. However, I am unable to make adjustments or export files if the masters are on DROBO. I can’t even relocate them. I get an error message saying that there is not enough room on the drive that I’m trying to transfer them to (I’ve checked. I’ve got 100GB of space and I’m transferring 3GB of images). When I try to export files I get an error message saying that it cannot create a file for the version listed below … Also, if I turn on the quick preview the little yellow warning sign with exclamation in the lower right hand corner of the screen cycles on and off quickly. I’ve read that I should be able to work with referenced masters on a DROBO on a network or other NAS drive albeit at slower speeds than if it were on a local drive. Are there some settings that I should know about that will solve my problem? I have the latest versions of firmware and the Drobo Dashboard and I’m running Snow Leopard 10.6.4. My MBP is one of the current models as has 8GB of RAM. I’ve contacted DROBO support and they weren’t able to help me. Any advice is greatly appreciated.

The bolded parts make me think that your Drobo is on read-only mode. See this thread for more info: http://www.drobospace.com/forums/showthread.php?tid=1676&highlight=read-only

I don’t think it is in Read Only mode. I am able to copy files to the DROBO and rename them in the Finder. I get the messages “… not enough room …” and “cannot create files …” when the master files are on the DROBO instead of the local hard drive. When I try to export a version, it is to the local hard drive. I read the link that you posted. I’m not sure I understand all of it, but do I need to do anything beyond making sure I have permission read and write on the DROBO Public Volume?

Since my original post all my files in my Aperture library have become disconnected. Not sure why. When I go to reconnect, I have to follow the path That is part of the serial number for my DROBO. Here is the path: DROBO serial #>1>Public. I’m thinking I might need to make the DROBO a static IP to start with. Any ideas?

Hmm, check that the folder is still DroboMACAddress/1/Public. On my Macbook (for whatever reason) it became DroboMACAddress/3/Public, and the ‘1’ folder is just a ghost folder now.

BTW, if you are able to copy files to the DroboFS then it definitively is not on read-only mode.

Problem solved. For those of you unable to sleep because you were waiting for a solution, here it is: With the help of Drobospace user ricardo, it turns that Aperture doesn’t appear to like the path created when the DROBO Dashboard mounts the Public volume, which is where I am storing my photos. When I mount the volume manually, I am able to browse, make adjustments to, and export referenced images from Aperture without errors. Thanks again to ricardo for all the help.

You’re very welcome. I’m glad it worked fine.

For what it’s worth, the same thing happened to me with Picasa. While I had Drobo Dashboard mount the shares for me Picasa would always “forget” about the pictures on the DroboFS (always re-indexing, re-scanning for faces, a real pain). Once I switched to manual mounting everything started working perfectly fine.