Drobo

Access iPad on Drobo

Anyone come up with a successful solution on accessing Drobo files via an iPad app?

I tried Filebrowser but for some reason I can’t get it to work. Not sure if its not “seeing” it despite being on local home wireless network or because it keeps insisting on login credentials even though I have none set for the Drobo.

Any case a Google search isn’t coming up with much so hoping the experts here might have some ideas.

Thanks.

Another app that can connect to CIFS/SMB shares is iExplorer HD. Don’t know if it works with the Drobo. The app is more expensive than FileBrowser and does not have a trial version to test out.

Goodreader

I tried that but for the life of me can’t figure out how to access a network drive from it. It seems it is setup to “cloud” solutions and FTP sites but not a standard network drive. Unless I am missing something.

Thanks for the ideas, anyone else come up with their own solution yet?

If you setup a web server then you could use Safari on your iPad to access your Drobo.

This will let you view any compatible files (e.g. text, pdf, quicktime, mp4, etc).

I’ve had a similar experience with FileBrowser/NetPortal in using their “lite” version to see if it works. After checking out their troubleshooting page: http://www.stratospherix.com/support/interactive_troubleshooter/nas-root.php it turns out they suggest that older versions of Samba (SMB 3.0 and below) are the culprit and that the Droboshare uses one such older version.

They specifically list the droboshare as one of the NAS devices that doesn’t work:

This list contains units that don’t seem to work, though it’s always worth trying yours in case different software in the device allows a connection.
DroboShare
Galaxy Metal Gear Model 3507LR
IOMega Home Network Storage
Maxtor Central Axis NAS
Raidsonic 900

That being said, I am currently using the NitoTv plugin on my 1st gen Apple TV to automatically mount my Drobo units via SMB, so it’s certainly possible. I’ve written to the makers of FileBrowser to ask for more info in an attempt to overcome this hump. If anyone has any additional information, I would love to hear from you.

So, after speaking to someone at Stratospherix, they mentioned that an update to FileBrowser had been submittedmto the App Store. The update includes a new setting called “Compatibility Mode” that will allow users to access their Drobo’s via the Droboshare.

Sure enough, the update was listed in the App Store 2 days ago, I bought the app and it works beautifully! They even added a couple of enhancements including the ability to swipe to the next file/photo, rather than backing out to the directory listing again. I couldn’t be happier.

Note, the rep I spoke to said that the “Compatibility Mode” toggle would be added to NetPortal “eventually,” but he didn’t give any kind of time frame.

I am trying to use Orb to access files on my droboFS via the local network and am having trouble with a few things.
I can’t open a pdf file larger than 1MB, indexing seems to corrupt itself if it is refreshed vs the initial install index capture.

I have tried netportal but it is formated for the ipod and at 2x pdf’s are not readable and I am not sure that they will change that anytime soon.

Airvideo works alright but only for videos (Orb is quite good at this as well).

I would really like one simple solution for accessing all manner of file types that reside on my droboFS via my existing local network (and perhaps remotely at a later date). Perhaps I am asking for too much…

LIS, if both the Drobo FS and your iPad are on the same local network, then FileBrowser that techlifter mentioned above should work.

Orb is designed for remote (outside your local network) access.

If they’re both internal, a direct SMB/CIFS connection is far more direct and efficient.

im thinking it should be much simpler than this…
set up an ftp site thats just for your own network, and to access it via the ipad via the ip address.
(then to swap out the password regularly to avoid snoopers etc)? :slight_smile:

i use GoodReader with FTP setup on the Drobo

I use FileBrowser on my iPad and can access all my shares just fine. I also use IP instead of NetBIOS name or anything of that sort just in case.