Access Denied message on a particular file

hi guys,
recently we had bad storms in the uk, and we lost power.
(i didnt have ups sorted out yet, but thankfully had dual surge protectors for when the power came back on)

it might not be related, but i noticed 1 large file on my drobo which says “access denied” when i try to do anything with it.

the file is around 30GB which is fairly large, but it hasne been modified for quite some time (it was a backup i made months ago).

the only thing i did recently was to move it from it’s current location, into a subfolder (just to tidy things up a bit) and that was about a day ago…

that worked, but when i tried to move it again (cut/paste or drag move) it says access denied.

  • i tried rebooting the machine, and trying from a windows cmd prompt, but still no luck.

  • also tried checking the attrib command (with -r as i made it read only for saftey) but access denied.

  • even a usual file properties in windows (to untick the read only) says access denied.

  • i ran a chkdsk on the gen 1 (x both volumes, and had to run it again in /x mode a couple of times until it says no problems)

  • gen2 showed me the no problems message with a basic chkdsk driveletter:

the funny thing is that both the gen1 (above) and gen2 drobos were in use at the time of the powercut, (just a couple of unrelated programs open) and ive been able to do the same cut/past/move operation on the gen2 file since then.

but the same file on the gen 1 seems to be locked somehow (even trying to copy it or use it in another program says Cannot Open…)

a general feature ive seen on windows 7 is a Security tab when looking at file properties in general, where you can adjust users/owners & permissions etc, but i cant seem to see that on the gen1 drobo which is on XP.

my xp machine is ntfs, and the drobo’s are ntfs as well… any inputs or thoughts are most welcome :slight_smile:

Is the path particularly long?
Can you copy/rename the file in Command Prompt?

hmm the path is total size about 50 chars including filename.
i didnt try to copy or rename in cmd, (had only tried move and attrib) thanks i will try that…

(in the meantime i’ve also fully shut down the machine, and this time also cold booted the gen1)

fingers crossed…[hr]
after rebooting the drobo and windows
and after opening a windows cmd prompt

all of these give an Access Denied message when i try them:

the only other thing i can think of, is maybe somehow windows is using/locking it
even though just before trying the above, i did a Process Explorer and searched for all handles containing part of the filename, and no results were shown. (before the reboot there were at least 8 things having used handles in explorer, and even dashboard said that the drobo was still in use)

ive made a dos boot disk, and will try a safemode boot, and floppy drive boot to see what happens…

heres an update:
i booted in safe mode (safe normal)

tried things again, and still did not have access, though this time, it showed me the Security tab (apparently it only shows when in safe mode or when logged in as an admin)

i noticed that the file (and its parent folder) are having a Different owner than most of the files and folders.
eg the “Administrators” owner.

i managed to toggle the special permissions Inherit from parent checkbox, and chose Copy instead of Remove, and that seemed to reset the permissions somewhat on that large file.

without logging out, i tried the same copy and rename tests etc, and they let me do it, so i marked it Non-read only for now. (but this safe mode account, wasnt able to even look inside the subfolder which i made using the normal user account) :slight_smile:

Now im running a quick chkdsk on the c drive while im here, and will then reboot and try windows normally again and see what happens. (why windows ntfs and permissions are so convoluted is still a mystery - there should be a simple program that you use to simply make this file/folder and all within it accessible to all user accounts on this machine, if desired, with a simply click or command) :slight_smile:

(incidentally, i also noticed a bitmap picture i made i think in mspaint ages ago, which was the only file in the root folder that was also having “administrators” as the Owner listed in the owner column - not sure what happened there) :slight_smile:

success :slight_smile:
it let me move that file using my normal xp logon[hr]
(so far, i think it was just down to a windows nfts permissions issue, and not the drobo - so if this ever happens to you, try the above solution and it might fix it too) :slight_smile:

If the path is too long , you can fix this by using Long Path Tool.