Drobo

A file that cannot be deleted!?

Hi All,

I have a file that cannot be renamed, moved, deleted, etc. I get a “The operation can’t be completed because an unexpected error occurred (error code -8072)” message.

I’ve tried to delete it in terminal and lots of other ways. No joy.

I’m running Lion, but the file was like this in the last few OSX versions as well.

I asked Drobo support, but they told me to move my entire Drobo FS data to a new volume and then wipe out the original volume to fix this. Ugh.

Any advice?

One weird thing is that if I do a Get Info on the file, under “Sharing & Permissions” I see “You have unknown access” and I can’t change any of my access privileges either.

  • Thanx in advance for any suggestions that might help!
  • Jon

Best bet, enable SSH access and try to “rm” it directly on the device. However, I’d be worried that if something is preventing deleting a file, there may be some subtle filesystem corruption - which can be death given the way Drobo redundancy is implemented.

My advice - enable SSH, then try to “rm” the offending file. If it works, force the DroboFS to run a filesystem check. If it passes, breathe a sigh of relief and move on. If something doesn’t work, take DRI’s advice - although it can be difficult given the amount of data you can put on a Drobo.

THANK YOU diamondsw! Worked like a charm!!!

  • Jon

How do you force the FSCK with the 1.2.0 firmware? I’ve read that CTRL-SHIFT-M from the Dashboard is supposed to work, but it doesn’t for me. Also if I try fsck via ssh, I simply get a “not found” error.