8TB drive problems

I have a 5 drive Drobo FS NAS that I have had for a couple of years. Recently I purchased two 8TB drives to upgrade storage. I removed one drive and replaced it with the first 8TB drive after two days of rebuilding the light went from flashing orange to green, everything went fine to this point.

I then ejected another drive and replaced it with the second 8Tb drive. After blinking orange for 8 hours it started blinking red. I removed the new drive and reinserted it. Everything seemed to be ok and it went back into rebuild mode and completed fine after another two days the light went green and everything was fine.

After about another day passing the same drive started blinking red again and every time i reinsert the drive i just goes back to blinking red. I even tried inserting the drive into a B800 drobo I have and I get the same blinking red. So I assume the drive is d.o.a. I inserted in into my computer and ran a s.m.a.r.t. test on the drive that lasted over 5 hours and the s.m.a.r.t test shows the drive to be good.

While I don’t understand why I guess it is possible for the drive to be good but for the drobo to be looking at a different aspect of the drive and to think it is bad.

I am really looking for comments on what the community thinks I should do next.

Personally, I would return it and exchange it for another. I have five 8TB drives in my Drobo S since about April and have never seen any of red lights.

hi oakmist,

if the 1st 8tb drive is working fine, and just not the 2nd, then yes its probably best to rma it as elai suggests. (which make and models were they by the way, and was the 2nd one different to the 1st in some way?)

if you happen to have another spare drive (different than the 8tb) maybe you could try it in that empty slot (just in case that slot has somehow become damaged)?

also, there is a useful tool by western digital which can scan all sectors on the drive as well, and has worked with non-western digital drives too, (it took me about 17hours to scan a 1.5tb drive on a slow system, where i think others have done it in far less, but on 8tb im thinking it would take more than 5hours) - might be worth running that too if you still have it and have time.

Just an FYI, WD Tools don’t always find something with a drive when a Drobo marks it as being bad. Sometimes, there are no bad sectors and the drive just isn’t responding within proper time limits so the Drobo starts flashing red. RMA the drive and stick another one and it’ll likely work fine. I’ve had to do this with a couple Western Digital drives lately that, after running WD Tools on them for 20+, hours tested fine.

thanks for that info… (im currently running the wd tool scanning almost 4billion sectors on my 3rd out of 4 drives prior to using 4 x 2tb drives in my newish drobo 5d) :slight_smile: