Drobo

800fs Filesystem Repair?

Got an 800fs with several folders that can’t be deleted - says they’re not empty (even after doing sudo rm -rf /nameoffolder/).

Tried doing a chmod and learned that the file system still thinks (inodes and stuff I’m guessing) that there are indeed files in those folders and gives me the names.

Tried using touch to create files with the right name in the right path and delete that, but no luck. Even after deleting the new file it still thinks the files are there.

Disk Utility or Disk Warrior, from my Mac, would be great tools, but they can’t see the unit since it’s a network mount. Drobo Dashboard > Tools doesn’t have the ‘repair’ option as mentioned in a knowledge base article.

So, how do I fix the file system.

hi, are you still in warranty for your drobo?
(it might be good to try saving a diagnostics log and raising a ticket with the support team, which you can still do in case not in warranty, though if you are out of warranty there would be a cost though)

it may also be a case where you might need to shutdown the drobo and restart again but how are things going currently?