5N in Critical Condition - Help!

Hello All,

This past Monday morning I came into the office and noticed that the Drobo 5N was not visible on the Network. Upon reviewing the Drobo dashboard I was presented with a message stating that there was an internal problem, the Drobo could not mount, and that I should contact support.

I was informed that we experienced a power loss over the weekend, I don’t know if that had anything to do with my issues.

I was then notified that the drobo had a firmware update available, yay! (I was currently running 3.5.10 [8.89.80777] Unfortunately, the new firmware failed to install. No problem, I will try manually. Again, a failure to install after multiple attempts.

The Drobo system itself is critical however all of the drives are healthy. After reviewing support documents I decided to run a repair via the dashboard. I followed the instructions to the letter and cloned all of my drives (using Data Rescue 4) before running the repair. (It is interesting to notes that when cloning the drives I only ran into 130kb of bad bytes on the drive from the first bay. The rest were flawless.)

Again following the support docs I downloaded a diagnostic before running the repair with the Clone drives in the Drobo. After running for about 5 minutes the dashboard notified me that the repair was successfully. Except it was not, the system information tab still reported health as “critical” and the system would not mount.

I downloaded another diagnostic and attempted the repair one more time (the support doc stated to not run the repair more than twice). This time nothing. I listened for any drive activity at all to encourage me that maybe the repair was in fact running. Nothing.

I then proceeded to remove all drives from the system and attempt the dreaded pin hole reset. After going through the reset process the Drobo 5N still reported critical health and would not mount.

Just out of curiosity I loaded a blank drive into the first bay, after some time it appeared that the Drobo formatted that drive successfully and reported it in good health on the dashboard…but the system still would not mount and health is critical.

One more time I tried a manual firmware update on a PC (up to this point I was on a mac) with a brand new ethernet cable. Failed to install.

Another interesting note is that after 20-30 minutes of sitting idle, the Drobo will simply disappear from the dashboard and the only way to get it back is by power cycling the unit.

I apologize for the long post but I wanted to give you all as much information as possible. I sincerely appreciate any suggestions you guys might have. Thank you or your time!

hi, thanks for detailing out the sequence of events.

as a first suggestion, if you are already in support, i would recommend raising a ticket for the support team. (you can still raise a paid ticket in case out of suport though if you are in its definitely worth raising one)

can i check when you mentioned this:
“Just out of curiosity I loaded a blank drive into the first bay, after some time it appeared that the Drobo formatted that drive successfully and reported it in good health on the dashboard…but the system still would not mount and health is critical”
(was this blank drive, the only drive inside the drobo, essentially being a 1-disk diskpack after the pinhole reset, or were any other disk pack drives also in the system?)

some quick checks could be these:

  • to power off the drobo (ideally via dashboards shutdown command)
  • to remove all drives while drobo is switched OFF and power and connection cables are unplugged.
  • to power up the empty and unconnected drobo
    (does it power up and then go into standby mode?)
  • to then power up the computer and dashboard
  • and to then connect it to the computer
    (usually an empty working drobo should be found by dashboard, but does it wake up shortly afterwards, and become recognised by dashboard for you with a 1st bay red light?)

if it still has problems, it could be a hardware issue but this is where a diagnostics log with the support team could help determine. if it is only the 5n that was damaged somehow, then you might be able to follow the migration process to use your diskpack in another replacement model, for example as mentioned here:

another test you could try, would be to try putting your drobo into readonly mode, as mentioned here, to see if it stabilises things to at least be able to access the data:
(readonly mode may need to be exited afterwards too)

i am not sure about the integrity of the cloned diskpack drives, (since runing repairs on them may well have modified things), but if you were to be able to have another fresh clone of your original diskpack, then another idea could be to try powering off, and inserting the clones into their same respective slots, but not putting in the drive clone that gave you some bad blocks… and then trying to power on and testing. (and possibly trying readonly mode if that does not work, just to see)

if the main unit was damaged by the power outage or a power spike though, then a good disk pack may still not work until a working replacement unit is used (including a good psu to play safe).[hr]
also please note: diskpacks should only be added in when power is all OFF and unplugged.

Hey Paul,

Thank you for your response!

In answer to your first question, yes the the blank drive was the only one in the Drobo at the time. I just wanted to see if the Drobo would even format it correctly.

I will try out your suggestions today and report back on how I fare!

Thanks again Paul!


I attempted the boot sequence that you suggested. Unfortunately I had the same results. The (empty) Drobo sits with a green power light and a sold Red light on the first (Top) bay.

I was able to place the 5N in RO mode and reboot with the clone disk pack in but unfortunately It still failed to mount.

I just received a new 5N that I ordered for Amazon and fortunately I was able to plug in the clone disk pack from the original Drobo 5N and it booted up flawlessly. Upon confirming that everything was in good shape I shut the Drobo down and booted it with the original (master) disk pack. I am back up and running with the new 5N…THANK GOD! I am delighted to report that there was no data loss. As frustrated that I am with this unfortunate event I have to say kudos to Drobo, whatever caused the unit to have failed did not effect my data.

I am still perplexed as to what actually happened to the old Drobo 5N. For the sake of curiosity, I have submitted a ticket along with my Diagnostic reports to Drobo support. Since my Drobo is out of warranty I had to pay the $50 to get support, but I’m sure it will be worth it. I will update this thread with my findings in an effort to help anyone who may experience these issues.

Thank you Paul for you suggestions and willingness to help!

ah cool thats great news :slight_smile:

it could have been powerspike damage, in which case it might be worth checking about the use of some ups and/or surge protectors (but please read up carefully about how to hook them up, as apparently if done the wrong way a surge can still traverse through connections, and like ghostbusters, you dont want to cross those streams) :smiley:

either way, am glad to hear you’re back up and running - please let us know how things go, and in the meantime, if you still have the clones, maybe keep them as a backup :slight_smile:

I’m curious if Drobo resolved the issue for you?

I was a Drobo fan. For its simple and effective data integrity. Peace of mind, even for a experienced IT guy like me.

Decided to buy a Drobo 5N. Newest firmware and Dashboard. Two Hard drives running smooth. Configuration fine. Some 50GB of test files written. All green to go.

Then I read hatchmarketinggroup post and decide to put my Drobo to the litmus test: just pulled its plug from the power outlet. I knew about the internal battery backup, witch gave me some confidence.

Same bad news. System never recovered by itself.

So, what is the point of providing excellent data reliability if it fails, I mean, dies, miserably in the first power outage? It’s an well integrated box goddammit!
My desktop running Windows and diverse hardware and software recovered itself with no hiccups from several power outages. (I do have a proper grounded surge-protected electrical wiring and a APC brand UPS.)

Even if I eventually get the system running again, following the procedures presented in this post, many hours will have passed. By then the best selling points of Drobo, the very same ones that made me buy one, will have gone down the drain.

Please, Drobo Inc, don’t tell me how effective is your support and that you can fix my unit for free. What happened with me, hatchmarketinggroup and many other furious users, just wasn’t supposed to happen.

What I didn’t tell is that I was planning to migrate from a 2HD Synology, not because it wasn’t good enough; the intention was to simplify my home setup with minimum configuration options.

Bad move.