Drobo

5N 1 red light/no volumes reported--HELP!

I logged into my iMac (MacOS10.15.6) to find my 5N showing no volumes (5 are installe; none have been removed), with one red light on front display (see attached screen shot). 5N worked fine the day before, but said there was in Data ProtectionMode and not to turnoff the Drobo or the computer. I left the iMac running and when I logged in again later, the 5N worked fine. The next day the 5N showed the red light. Went through diagnostic procedures on Knowledge Base with no change. Firmware is from Dashboard screen; no idea why it’s an "invalid Firmware Version). Not sure how to proceed: 1) is this a Drobo hardware, firmware, or software failure? 2) Is this 5N fixable? 3) Has this failure deleted or corrupted my data? 4) What do I do next to obtain access to the data on the 5N? I submitted a Diagnostic file before I opened this support ticket. After viewing the Support response, it’s seems pretty clear that 1) this is an “experienced” problem and 2) Drobo support doesn’t seem to care. Does anyone have a recent solution or am I now in the market for a replacement? Thanks.