Drobo

5D3 Flickers but won't power up

Drobo 5D3 doesn’t seem to want to boot up. Looking for advice. Is it dead?
I created a support ticket and was given a checklist about the following:

Things to check:
• yes power supply is correct and the brick is showing solid green light
• I was using a surge protector; I plugged directly into the wall
• I made sure the power is connected securely
• I unplugged the Drobo for 10 minutes, then plugged it back in and tried again - same result
• Power supply does not appear to be loose or damaged
• all the lights come on briefly when I toggle the switch (bay lights are yellow), but then they all go dark within a second or two (see video links below)

Things to try:
1: unseat drives and try to power on: done - no change
2: Power on - done
3: power on without drives? no, same thing happens with or without the drives - lights come on briefly then go dark
4: the light on the back (green light on the power switch) flickers in a strange pattern then goes dark - the pattern is always the same
5: the light on the power brick is solid green when connected to Drobo
6: the light is solid green when disconnected from Drobo
7: used power supply from an old Drobo 5S - same result: lights come on briefly, then go dark. Same flickering pattern on the power button when power supply is connected or the switch is pressed.

Here are some videos to demonstrate what’s happening.
If they don’t play inline, they should download fine.

Front panel

Rear Panel

Next steps?

Here is my original Problem:
Last time I had the Drobo working it was mounting only one of two volumes.

I opened Drobo Dashboard and it recommended I disconnect and reconnect the USB C to allow it to optimize; when I did, the Drobo powered down. Since then I am not able to get the Drobo to power back up.

When I press the power button, all the lights come on for a second (sometimes for a few secconds) but then they all go back out.

I tried restarting it with the USB C cable disconnected.
I tried unplugging and reconnecting the power adapter.
I tried ejecting all the drives (but leaving them half in the bays so as not to mix up the order)

I did notice that the green indicator light on the power button on the back of the unit does flash an odd pattern when I press it to try and power the Drobo on. I don’t recall ever having paid attention to this light before so I don’t know if what I am seeing is typical behavior or not.

I did notice a few times prior to this failure to power on that my Drobo seemed to have powered itself down; the volumes were not mounted and all the front panel lights off except a red dot on the lower left corner. Whenever I would notice this, powering the Drobo on using the power button would not work, but disconnecting the Drobo from power by unplugging and reconnecting the power adapter would bring it back online.