Drobo

5d won't power up, powersupply solid green

I’ve had my 5d for 2 1/2 years with no problems so far. Yesterday when I hit the power switch it failed to start up right away, so I had to hit it again. It worked and thought nothing more. So far so good. Today I hit the switch again, and the lights came on briefly, then almost immediately turned off. I tried again and noticed that the fan spun as the lights briefly came on, then it just stopped turning and the lights went off. I tried multiple times with the same result - fan briefly turning on/lights briefly flashing on, then everything goes dead. The power supply light is solid green. Thoughts?

Good Morning Tom to answer your question you would need to try and check the following

1-Does the Drobo power on without the drives installed?
2. Is the light on the back of the Drobo lit when the power supply is plugged into the Drobo?
3. Is the light on the power supply flashing or solid when plugged into the Drobo?
4. Is the light on the power supply flashing or solid when not plugged into the Drobo?

Thanks for the fast reply.

  1. No, it does the same thing, briefly turn on, lights flash, then off, including the light on the back of the Drobo.
  2. No. If I plug the power supply into the Drobo it flashes on then off immediately
  3. Solid green when plugged into the Drobo.
  4. Solid green when unplugged

That Sounds like you need a new unit replacement ,I would seek attention from the support team ,if you have a warranty or drobo care.

https://supportportal.drobo.com/retrieve/s3/knowledge/AA/AA-01858.html

So, unless the unit is under warranty (it isn’t), I have to buy a new unit and migrate the drives? No other options?

Yes you would to purchase another drobo and Ensure that your Drobo is using the most current firmware and the latest Drobo Dashboard.

This might be useful :
https://supportportal.drobo.com/retrieve/s3/knowledge/AA/AA-01707.html