5D Not Mounting (Mac)

I have been trying for months to get a reply and help on my tickets but they keep getting closed out…

So, I’m looking here for help.

A power outage in my neighborhood abruptly shut down all my equipment and ever since my drobo won’t mount to my computer. (iMac 27" 2017 Ventura 13.1) I connect via thunderbolt and have bought a new cable to eliminate that as an issue and have tried hooking up to another computer.

This has happened in the past thanks to California’s rolling blackouts and Drobo CS recommended using Disk Warrior which originally worked, but does not for this issue. Disk Utility shows nothing, so neither does the dashboard. I’m stumped and have 13tb of my work that I cant access.

Can somebody please help me?!

First check:
The 5D comes with USB as well - check whether you can re-establish connection with this option

Second check:
Even though you have not mentioned whether the disks are ‘green’, your power brick may have been affected by the abrupt power shutdown and is now not providing enough power. Consider replacing it and ensure you plug directly into a wall outlet.

Third check:
You need 2 spare HDDs - small capacity but make sure they are compatible with Drobo (not SMR)

  • Turn off your Drobo (even remove power);
  • Eject you current array (mark their order);
  • Insert the 2 spare HDDs;
  • Reconnect and boot up;
  • Review if your Drobo become visible on your Mac - if so, let it go through the process of establishing the new array (even test it by moving in a test file);
  • When complete, close down and turn off your Drobo;
  • Eject the 2 HDD array, reinsert your original array in order;
  • Reboot.

Hope at least one of these works - this is also a reminder to maintain a current external copy/backup of your important data as a single point of failure is always your RAID machine regardless of its make.

Good Luck!