5D Not Found Using USB 3.0 or 3.1 Ports

I have seen several threads about this and no one seems to have found a solution. I have had this issue for several months where my 5D isn’t recognized when plugged into a USB 3.0 or 3.1 port. I works fine on a USB 2.0 as everyone else has experienced.

My older mother board had a USB 3.0 port that worked just fine using Win 7. Since upgrading to new motherboard and Win 10 Have not been able to use USB 3.0.

I have a 5D with latest 3.5.2[7.179.86336] Firmware and 3.0.0 Drobo Dashboard version.

Mother Board is ASRock X99 Taichi which has USB 3.0 ports, a USB 3.1 Type A port and a USB 3.1 Type C port which I understand is same as Thunderbolt.

  1. I have read on this forum in the past that Drobo has and updated cable for USB 3.0 that functions properly. Has anyone heard this and if so where to get the cable?

  2. Is it possible to use the USB 3.1 Type C port by buying a Thunderbolt cable? Has anyone had any success doing this?

hi john,
are you able to see any settings in the bios, that might possibly show if usb 3 is enabled?
(i havent used an asrock for a while but there might be some settings worth at least checking in there to see, in case not already tried?)

also, in windows, is there a way to check if there is a newer usb driver for your system?
(maybe for a usb 3.0 root hub, or usb 3.0 host controller)?