5C saying no drives are installed, all lights red, can I plug them into another Drobo?


I’m hoping someone can help me. I have a three year old Drobo C which has been working flawlessly, first on a Mac and now I’m using it on a Windows PC as storage for my media server.

First the background to my problem and how it started.

Recently, I noticed the fan was starting to get a bit noisy and so I looked into replacing it. I found plenty of guides showing how to do this on a 5N and as my 5C looks very similar, I thought I’d go for it. I found a suitable fan and started work. The fan specificatios were exactly the same as the original except it was rated a little quieter.

I’ve been a radio ham for over thirty five years and am no stranger to using a soldering iron. I went into this confident that I could do it all without any problems. I took photographs as I took it all apart so I would get everything back the same way. I took pictures of the drive layout so I would be 100% sure that they all went back in the same order.

I replaced the fan with no issues but ran into two problems when I booted the Drobo for the first time. The fan was trying to start and pulsing on and off but worse, as the unit went through the boot sequence, the LEDs started going along the bottom, all the drives span up and then all the drive lights went red very quickly, one after another from top to bottom.

I took it all apart again and checked everything - It was all fine, nothing was broken, incorrect or just plain wrong. I’d read of some people with this fan issue so I simply put the original fan back.

However, I’ve still got the same problem with the drives. It simply fails to recognise that any hard drives are in the unit.

The dashboard recognises the Drobo and it tells me that it has no drives.

Today I’ve replaced the PSU because I read one report from someone who reported similar and it was the power supply.

That hasn’t fixed it.

At no point has the Drobo been fired up without the drives in the (correct) bays, I’m not getting the message telling me that too many drives have been removed, it’s still the same thing saying no drives are installed.

I picked one of the drives at random, plugged it into a caddy and connected it to my iMac. Disk Utility recognises there’s a drive attached but obviously can’t read anything from it. This tells me that the drives should be good.

So with all that explained, here’s what I want to do and I’m hoping that someone here can advise.

A friend of mine has a couple of Drobos, I’m waiting for confirmation of what model they are but I think they’re 5Ns.

My Drobo is formatted as NTFS under Windows 10.

Could I take my hard drives out and plug them into his Drobo? If I do this, will it be able to read the data from them?

If so, that’s fantastic because I have about 8Tb of data. I can then copy the data elsewhere and I’m good to go.

If I can do this, can I then just plug his drives back in to his Drobo and it will recognise them and work as it did before I put my drives it?

Although technically I have copies of all my media, I would have to recreate the entire directory structure and that’s a big job. There’s probably ten years worth of media from multiple sources (mainly iTunes) on there.

I’ve never specifically bothered with backing up the Drobo simply because I do have the data elsewhere but it’s struck home how much work there is for me to re-create the libraries and that’s not something I want to do. Yes, I know. I preach to people about backups and everything else I have has multiple backups, just not the Drobo.

I’d really appreciate any advice anyone can give please. If I put the drives in a different Drobo, will it work and can I revert that Drobo back to the drives it had in before?


I can’t talk to moving your drives to another Drobo, as I have not had that experience.

If you want to give your 5C another go however, and assuming you have the latest Drobo Dashboard on your PC, you could try to activate it without HDDs and see if you can first regain connectivity. But you will need some spare HDDs to help reset it.

1 Shut down your Drobo completely (I would even remove the power cord)
2 Remove all your HDDs (note their order)
3 Restart the Drobo to see if it mounts and becomes active (even update any firmware).
4 Insert the 2 spare HDDs whilst it is running and let the Drobo format them (all green)
5 Perform a factory reset
6 Shutdown the Drobo and remove the 2 HDDs
7 Insert you original HDD pack in the original order
8 Restart.

Do NOT remove or insert your original HDDs whilst the Drobo is running or you will lose all data.
Hope this proves useful for your data recovery.

Hi and thank you so much for the reply.

Right, I’ve got this far (and it did update the firmware, even though it hadn’t previously offered me an update).

Now on step 4, I’ve put the two spare drives in and the dashboard recognises them with a health of ‘good’ but it won’t let me do anything.

The first email warning it sent was:

Too many hard drives have been removed. Please re-insert the removed hard drives.

Then it sent me two more telling me that it’s detected new drives:

Drobo detected new drive(s) added.

======== Drive 0 ========
Product ID: SEAGATE  ST3500320AS
Serial: 9QM0TPE4
Health: Good
Capacity: 500 GB
Drive Type: HDD
Drive Interface: SATA


Drobo detected new drive(s) added.

======== Drive 1 ========
Product ID: SAMSUNG  HD103UJ
Serial: S13PJ1CQ802427
Health: Good
Capacity: 1 TB
Drive Type: HDD
Drive Interface: SATA

Because a picture can paint a thousand words, here’s one picture with what I’m seeing on the Drobo and the dashboard (if you click it, it’ll appear full size and actually be readable).

As you can see, I don’t have an option here to format them and the Drobo isn’t doing that itself.

What do you recommend from here? Should I do a factory reset and let the Drobo format the drives? If so, what’s the exact process to follow from where I am now please?

Thanks again.


Hi Keith,
Yes. Factory reset and let the Drobo format the 2 spare drives.

OK, thanks.

Once I’ve done that do I then shutdown (including remove the power), put the original disk pack back in and hope? :slight_smile:

Before you removed the 2 HDDs and shut down - were they formatted and come up green after the reset?

If so, yes. Moment of truth.

I managed to find a couple of additional 1Tb drives so I’ve removed the 500Gb and I have two 1Tb drives plugged in.

So I’m currently looking at a powered on Drobo with two hard drives all formatted and green.

One thing before I go any further. My original drive pack was configured as dual drive redundancy. Should I plug in my third 1Tb drive and configure the Drobo the same way before I go any further?

Sorry for what may seem like silly questions but I just want to be sure :slight_smile:


OK. I can’t answer that for sure but, for all the effort in setting it up in the Drobo in as similar configuration to accept your previous drive stack, I would say yes, add the third HDD and set it all up for dual drive prior to the exchange. Remember to power off the Drobo before the swap out.

I’m expecting good news (!!)

Cool, it’s doing that now - It currently says it’ll take an hour to complete (although I expect it will be shorter as there’s no data on it) and once that’s done, I’ll shut down, remove power, put my original drive pack back in and cross my fingers!

I’ll ride it out with you. Let me know.

No, it hasn’t worked.

Drobo does not detect any drives. If there are drives installed, please safely shutdown the Drobo, reseat the drives and restart the Drobo. If this does not resolve the issue, please contact Support.

The stupid thing is that the dashboard does see the drives, this is the correct configuration.


Can you let me know what the Drobo reports about one of the drives, by highlighting it?
Odd thought. If you have 5 spare drives, can you load all 5 of them as you did for the 3x spare HDD so that the Drobo is then expecting 5 drives (and not perhaps 3?).

Here you go

I can just about cobble together five drives, it’ll be three 1Tb and two 500Gb. I’ll do that now.

It’s doing the dual redundancy work again and says an hour.

OK. I check back later.

If there is no improvement, the only remaining thought I have at the moment is that the RAID directory across the disk pack could be corrupted, since your spare HDDs pack is recognised by the Drobo. On a Mac I would use Disk Utility or Disk Warrior to correct and optimise it, but I’m not sure what you may have that is similar on your PC.

Hope it all works out.

It hasn’t made any difference. The Drobo dashboard is still saying that it doesn’t detect any drives but that’s clearly not the case because it shows all the connected drives and the health status of each individual drive is ‘Good’ but the overall system health is ‘Critical’.

I do have Disk Warrior on my iMac but of course, this is formatted to NTFS which Disk Warrior won’t touch.

Windows Disk Management shows a ‘Not Initialised’ drive.

I don’t understand how the raid could have corrupted. I didn’t remove the drives when there was power, I know absolutely 100% that they’ve always gone in the correct order because I photographed it first and as the drives have been added and changed over the years, I can tell which order they’re in depending on when I got them.

I really don’t know where to go from here.

Hi Keith.

It does seem that it is a Diskpack problem rather than a Drobo one, so perhaps the focus moves to data recovery instead. There is another thread dealing with data recovery via proprietary software if you have the time:

Best of luck.

Thanks but I’m not going to bother. The spare drive pack works perfectly well so I’ve proved the Drobo is good but I just don’t feel as though I can rely on it any more.

I can find most of the media again, even if I have to go back to my physical stuff. It’s just not worth my time to spend weeks rebuilding it like that.

It’s going to be a pain in the arse but I’ve ordered a different manufacturer NAS and will rebuild my library on there. I’ve tested all my drives individually on the iMac, they format and DriveDX is happy with them all. I know the 5C is working and I’ve already sold it second hand for a song with full disclosure of what’s happened to it.

Thanks for the advice in here, shame it wasn’t to be.