Drobo

'5 minute' format taking hours

Basically had terrible performance on my 2x1,5TB and 1x1TB, support recommended i did a clean sweep, so spent 2 days (oh dear god yes it does take that long to transfer), then a reset. The soft reset didnt actually reset, and the drobo got all confused and kept restarting and spooling the drives infinitely until i removed all the drives or finally doing a hard reset.

Now finally doing the format in progress bit, but its taking HOURS. I remember first time it did literally take 2 minutes? Would the drive having random data on cause this, and how long am I looking at?

Sounds like there’s a hardware problem, though not sure whether it’s the drives or the Drobo chassis.

Once it completes, get the diagnostic log and send that to DRI support. They can tell you if there Drobo is registering problems with the drives.

Should only take no more than 5 mins. It could be an issue with a drive, or the corruption is so bad on the drive. Could also be an issue with the cable or port.

What is your OS?
Are you connected via USB or FW?

Also, please open a support case.

indows 7, firewire 800 via an external card + the 3rd party recommended firewire drivers.

Would you recommend cancelling this format (ie force closing it) and trying to format the drives manually or something else?

Dont think i mentioned but i dont need any of the data that is on the drives at the moment, I have copies on non drobo’ed drives. [yes i do like hard drives…]

EDIT: Oh hmmm, somehow managed to bring up the advanced controls window while its still formatting, and its saying "Data Protection: In Progress (approx. 33 hours remaining).

  1. How on earth is it formatting and rebuilding at the same time
  2. How on earth is it rebuilding even though i pulled out all 3 hard drives and put them back in
  3. Why is it rebuilding when I did a soft and hard reset (although that effing button is so hard to press I dont think it worked).

Help :’(

  1. because the hard reset without the drives would just clear the memory in the drobo

the information about your disk pack is stored on the pack itself. thats why if your drobo ever breaks, you can just pull the disk pack and put them into a brand new drobo and carry on as normal. so when you did your hard reset with the drives removed, its just like putting your existing disk pack back into a new drobo (since you had hard reset your old one). the disk pack would still be in tact.

you need to do a hard reset with your drives in - that will wipe the drobo and destroy your disk pack - you will have a blank drobo and blank drives, and you should be able to reformat in seconds :slight_smile:

I did the soft reset with the drives in but it crashed multiple times, and did (well attempted to) the hard reset with the drives in.

Anyway, after many flashing lights and crawling under the desk, now have a lovely new 16TB partition (first time around did 2x2 by mistake) with 5-6 times the transfer speeds I was getting before yay.

Also updated the dashboard in all the confusion, however its saying I have the latest firmware (which i dont [1.3.5]), is there any way to force update it? Gen 2 Drobo

1.3.6 is not an auto-update, it was designed for the 4k sector drives that are out on the market. You can manually update the firmware if you need it.

Ah right, cheers.

glad to hear its all sorted :slight_smile:

cries

Not so sorted any more. Drobo now randomly disconnects at will and dashboard reports “no drobo detected”. A reset does start the drobo going (although usually i have to switch port the drobo is on so it is redetected). After spinning up all the drives the drobo crashes to all lights off and stays that way till i manually remove its power/firewire.

Definitely time to get back in touch with Support… let us know how it goes.

agreed

Hmhhh, well after a lot of screaming at it and restarting, its working. Have a very traumatic log if any admins are around (i want to avoid support as it takes so long for them to reply/different time zones + work etc that the problem has changed by the time they do).

Not a clue what triggered the disconnect or the reconnect, all I know is it didnt used to do this before :confused: I really wouldnt mind shelling out a bit for a new Drobo S if they’d take my old (possibly a bit demented) drobo in part.

I STRONGLY advise you to get back in touch with support.

My experience in these types of situations (increasing difficultly getting things “started”) has always ended up with a completely non-functional device soonafter.

Had a system that was stubborn on booting. It took 2 or 3 power cycles, then it’d boot fine and run fine, until it was shut down, then it’d happen again. SMART status said it was good. About the 15th time of having to do the power-cycle to get it started up, it didn’t start. Drive diagnostics said the drive was completely undetected and the drive wouldn’t spin up at all.

Had a new system recently that suffered a similar problem. It’d run fine for days, then it’d be in a hung constant-beep state that required the system be completely powerless for 5+ minutes, then it’d be fine for a few days again. After two weeks of this, it went completely dead.

So I have learned, the hard way, that “pretty much working” is just a harbinger of imminent death. Don’t settle for anything less than fully functioning.

BTW: Do propose the “trade up” for Drobo S, it doesn’t hurt to ask… sometimes you are pleasantly surprised. :slight_smile:

I did when I heard they were first announced, the rep said “neg”.

Bummer, ah well, at least you tried. :slight_smile:

but that would be trading up a working one - which they dont have to take back… if yours dies - they need to ship you a replacement one anyway - so you could see if they would let you pay the difference to get a better replacement one

its definitely worth asking

Unfortunately we do not take trade-ins.

We do offer a loyalty program:
http://www.drobo.com/where_to_buy/clp.php

Lets be honest though, whats $50 off an $800 price tag.

Ffs disconnected, reset it and now just on one of its infini reset boots where it spools drives and then crashes. Something I have noticed is that when its spooling drives, my third monitor flickers :expressionless: how on earth is that even possible.

Monitor flicker can happen for a variety of reasons, especially if you’re on an analog connection.
It’s possible your power supply is wacky.