Drobo

4TB of data corruppoted - thanks drobo!

After firmware upgrading my drobo from 1.3.0 to 1.3.5, my entire file system became corrupt. I attempted to fsck the volume but it did 0 good.

So just wanted say thanks data robotics - for a product that lives up to most the hype, but can sustain.

Support Tickets:

rocky - 00041673
fynzh - 00041910

Did you open a support case? If so, what is the case number?

I really hope the OP opened a support case, otherwise it’s like the guy who complains that the Fire Department didn’t save his house but didn’t bother to call them.

I didn’t in fact - i’m one of those “sorta supported” linux folks. Last time i had an issue it was the community forums that solved my problem - back on the old forums…

and after fsck’ing using a back up superblock, pulling out of lost+found most my files, it randomly eats it’s self again.

When i down rev’d back to 1.3.0, the drobo reported a “unkown firmware” - anyone know what that is about.

[quote=“rocky, post:4, topic:530”]
I didn’t in fact - i’m one of those “sorta supported” linux folks. Last time i had an issue it was the community forums that solved my problem - back on the old forums…[/quote]
I would argue that the type of behavior you’re experiencing is probably independent of host computer platform but regardless…

At this point I’d see if DRI will swap/exchange units in the hopes that the drive pack itself is mostly OK and the Drobo itself has just lost its mind.

If you have some spare drives, you could eject the entire disk pack, mount the other drives and do some diagnostics. If the new drives do stupid things, then the fault is in the Drobo’s “brain” and any further attempts to “fix” the errors will likely cause more.

It’s like if you’re drawing a bunch of circles, then go to bed and when you wake up and look at your drawing, everything’s oval.
Without looking at something that you know for certain is a circle, you can’t tell whether your vision is just messed up (in which case “fixing” the ovals to look circular will actually break them), or if you were just really tired an actually drew a bunch of ovals instead of circles.

Hope you can recover your data.

Brandon

i have A spare drive, not more than one though.

Frustrating thing, friend of mine bought a drobo on my recommendation - he upgraded to 1.3.5 too…and same darn thing.

tried downgrading to a 1.3.0 firmware file i had saved - but it made things worse “Unknown firmware installed”. Guess the drobo must flag something internally when it upgrades to prevent downgrading.

Just a quick check here… after upgrading to 1.3.5, did you power-cycle the Drobo (unplug power, wait 20 seconds, then plug back in) unit? I had to power-cycle my Drobo after the firmware upgrade before it worked normally again, but mine is connected to DroboShare.

You cannot revert back to older firmware. That is why you are getting that message from dashboard. I recommend reapplying the 1.3.5 firmware.

Yeah, i did - still in the same boat though. Keeps randomly corrupting, send diag data to support.

Looks like if i wipe the drives in an external utility, i can downgrade the drobo to 1.3.0 - must be some header information stored in the drive.

Guess i’ll make my way to bestbuy and get some massive usb drive if support can’t help

Jennifer mentioned on another thread that there’s a firmware correlation between the disk pack and the Drobo itself.

I was told by Drobo support that you can only downgrade to 1.3.3 from 1.3.5

Hmm, nothin yet - ticket: 00041673

still sitting on my hands, waiting.

though my friend opted for wiping his disks, downgrading, and is happy.

I’m having the same problem.
The filesystem won’t mount, declaring a bad superblock, even after trying to fsck with a backup superblock.
The funny thing is that droboview still shows the correct capacity, so hopefully my data is still in there somewhere.
I also opened a support case today.
Here’s hoping we get a fix!

for what it is worth I opened a support ticket and once I called to follow it up got a few emails back, then it became too hard and never got any more replies from drobo support.

I ended up having to re-format the drobo and start over.

Yeah, now it doesn’t even work with the backup superblock. Same thing as you though, it still sees all the data in droboview.[hr]
perhaps we should start listing all the linux+ext3+drobo = sadness tickets here.

Sure!
I have case #00041910.

Has Data Robotics offered anyone any advice yet?

Nope - not a word.

updated first post though with our tickets.

Guh - support is saying “no one else has reported ext3 corruption” and “do you get this under windows”.

Well if i hook it up to windows, i’ll have to nuke and pave…trying to save my data here.

The windows comment makes me suspect the brush off is coming.

Yup - given the unsupported line.