3.5.2 permissions issues with 5N

I have a number of Drobo’s and the one that is upgraded to 3.5.2 with dashboard 2.7.0(tried .1 also) has introduced some weird issues.

Dashboard either as Admin, Guest or full permission user will mount the 5N. I appear to have full read/write access to the drive from the finder and terminal but only with this upgrade iTunes will no longer load from the mounted share.
I get a 13010 issue which historically has been a file issue but this problem is more complex.

If I tell iTunes to create a new blank library on a 5n with 3.5.2 it starts to create the files and fails giving the error. If i do the same steps on the same machine but with a drobo that has 3.3 it creates the files just fine. Something in 3.5.2 appears to be introducing an issue through SMB i would guess. If I tell iTunes to create a new library on any other drive (internal SSD, External USB, ThumbDrive, SD Card) they are all successful. The issue is only when writing to the 5N on 3.5.2.

Is anyone else having these issues? Anyone have any ideas. I can swap drobo’s out and put this on the shelf until they get it fixed and make sure none of the others upgrade to this firmware but i would like to try to fix the issue. Drobo support is telling me that downgrading the firmware could brick the device worst case so I don’t want to do that.

hi snl, you may have already tried this, but if not, it might be worth powering all down, and rebooting the drobo 1st, on its own (without network cable attached), and then letting it go into standby once booted up, and then to boot up the mac, and once that is booted, what happens if you then plug in the connection cable to drobo and try again?


Tested that booting disconnected from ISCSI and then connecting it to mac allows drobo dashboard to find the 5N and mount it. But the issue still persists.

Something else I noticed.

By default the share mounts with SMB and appears to have full privileges on the iTunes folder. DRWX---------@
If I mount the share using AFP, my user does not have access to iTunes folder and it is DRWX---------------.

A little googling tells me that the @ is extended permissions but its odd to me that if I mount of AFP vs SMB i have different access. Not sure if this is relevant or not, but just additional data points.

Hi snl,

I have the same issue.

Unfortunately Paul’s suggestion didn’t work for me either.

SMB doesn’t support the same set of extended attributes that AFP supports. I don’t understand the reference to iSCSI since the 5N doesn’t support it.

The 5n is connected via an Ethernet cable directly to the Mac mini. A second thunderbolt Ethernet adapter is used to connect the Mac to the network. The 5n is only visible on the Mac mini, not the network.

I may be mistaken, but per the instructions this should be an iscsi connection. The 5n does not have a useable ip and neither does the Mac as they are both 169 Addresses on the Ethernet to Ethernet connection.

The 5N does not support iSCSI.

A direct connection to your Mac will work (and will use SMB). 169.254.x.y address is a link-local address; its not routable, but can be used for direct connect.


hi, there was another post about connecting with afp which may help here:

Hello SNL,
We are sorry for the issue you are experiencing and we do want to get this issue resolved for you. Would you direct message me your support incident number. Downgrading your firmware will not work and is Not recommended.
Would you also let me know the name of the agent that advised you to downgrade your firmware, we will also have the call pulled.
Look forward to hearing from you. Thank You.


My situation is a little different, as I use the 5N as a NAS. I’m using Drobo Dashboard 2.7.0 (2.7.1 is not available to me yet) on OS X 10.11.2.

When I connect to the share using AFP (and leave the share unchecked in Drobo Dashboard). I noticed that on all the “old” folders within the share, the permissions are drwx------ and the content is not visible to me anymore.

A newly created folder gets the permissions drwxr-xr-x.

When I connect to the share using Drobo Dashboard the share has the same permissions as before using AFP (drwx------@). I noticed that there is an extra entry in the Volumes folder (Drobo5N with drwxrwxrwx+ permissions). Permissions of the folder inside the share are the same as before. In Terminal I’m still unable to look into the folder, but in the Finder I can now see the content of the files and folders.

Finder doesn’t show me the permissions, it only tells me that I have custom access.

Firmware 3.5.5 for Drobo 5N resolves the issue (for me). iTunes is back to normal again. Thanks snl for reporting it and Drobo for resolving the issue so quickly.

Good day,

I’ve been running into this issue, and have contacted support as well, seems like they’re dropping the ball a bit. Not their fault probably have their hands full.

Refrence# 160108-000023
In any case, could anyone point me to a fix.

I have had the same issues.
I can create a new iTunes library on my local machine fine, however, get the dreaded 13010 error on my Drobo 5n
I’ve been running my library fine for 2 years on the 5n. The problem popped its head out yesterday after some reboots which are far and few between.

cool for strikpmj that its working again for you,

hi tfraley,
there is some info about that error here with a possible fix that might work for you, but if you can, it might be worth waiting for support first, or at least to take a backup of any files ths webpage mentions deleting: