2nd gen Drobo in perpetual "Data Protection" mode?

About a week and a half ago I came to my comp after copying a few gigs of stuff to my drobo and noticed that all 4 drives were blinking orange/green. I looked at the drobodash and it said Drobo was in data protection mode but still useable and “Do not remove any hard drives with blinking lights” (which I guess means don’t remove any drives). That was around 8-9 days ago, I had a power outage and so, like it or not, the drobo was “powered down then powered up again” and it went right back to the orange/green blinking. Should it really take this long?

-I am running win10.
-Dashboard 2.8.5 [87185]
-firmware: latest probably (dashboard now doesn’t see my drobo but I usually update everything when I am told something new is available).
-I can access my drobo
-I have three 3tb drives and one 2tb drive, around 70% full last time I looked (7 of 10 blue dots showing up, no messages about running out of drive space)
-its connected via usb 2.0

Any help would really be appreciated!

hi gaikokujinkyofusho,
i was just checking your info above, and as far as i can tell, your gen2 drobo will be using Single drive redundancy (SDR) mode by default, and your setup looks to be having the following.

3TB + 3TB + 3TB + 2TB = 11TB Raw
11TB (-3TB for sdr, as 3TB is the equivalent size of your largest drive) = 8TB actual
8TB (*0.9 for filesystem overheads) = ~7.2TB

even though you are only using up about 70% of that, the gen2 usually takes about 1 day per 1TB of data that you have, (and can be a bit slower depending on if something was accessing the drobo for a while)

in some cases the computer or dashboard can lose access to the drobo, though if you are able to please try waiting some more time, it should hopefully finish soon for you.

(usually the drobos can recover from a power cut and continue again, but just in case something happened and it wanted to restart the rebuild and recovery process from the start, it would be good to try to leave it for another week (if you can) just in case - though hopefully it should finish sooner.

please do let us know how things go

Hi, I have let my drobo run (no power outages/shutoffs/reboots) continuously since my last post and well, its still blinking orange/green. The dashboard doesn’t recognize it anymore and its no longer showing up as a drive on my computer. So now its been 11 days ago… are there any other suggestions on what I might do to get it working properly again?

thanks for waiting and trying that…
can i check if you are sure that when you say orange / green, do you mean red/green?
or is it possible that it is actually yellow (or amber) / green?

sorry as i know it can be a bit confusing as even some knowledgebase articles refer to yellow as orange, like here:
http://support.drobo.com/app/answers/detail/a_id/158/~/what-do-the-led-lights-next-to-each-drive-bay-on-drobo-indicate%3F
but i think if we can be sure about the exact colour it will help…

if you have ever seen a drobo having basic colours or Yellow, Green, and Red, and if you can have a quick look here, are you able to confirm the colours?
https://myproducts.drobo.com/article/AA-01770

the reason i ask is that there was a similar question here, with red and green lights, but the rebuild ended up completing ok: http://www.drobospace.com/forums/showthread.php?tid=147406

Fair enough question, but I am sure its orange (or amber/yellow) as I have seen red, and endured a rebuild before.

thanks for the information,

if you are able to wait until the weekend, for example on sunday, this will be a good way to allow ample time, (just in case) a full 8days of rebuild took place (and something triggered it again), allowing 16days total to elapse.

but for the rest of the time, if you can please shutdown any computers the drobo is connected to, does the drobo still continue to do what it is doing currently?
(if after 10minutes it continues, please can you unplug the connection cable from the back of the drobo, in your case the usb cable)
after another 10 minutes does the drobo go into standby mode?

if not, please allow it until sunday if you can.

if it does go into standby mode (or if we reach sunday without change)
then if it does not seem to be progressing, then one thing you could try could be to power off the drobo from the mains, or to unplug the power cable, and to wait 10minutes.
and then to power it back up (still while unconnected to the computer)

does it boot up and show the same thing as before,
or does it seem to boot up as normal (with blue led lights from 1 through to 10, usually from right to left?) and then does it show solid colours for the drive bays such as all green, and then does it go into standby mode?

(in case it seems to hang during the blue led lights 1-10, then please allow plenty of time here in case it is self correcting during bootup)

if it does seem to boot up and go into standby mode (or if it shows flashing colours), can you then start up the computer, and dashboard, and once those are loaded up, to connect the usb cable again…

what happens now on the drobo, and can dashboard find it and show any more info there too?[hr]
by the way, if you happen to have an easy way to take a quick video clip or photos on your phone, to post to youtube (or images to imgur) that could be useful too if you can.

(please remember to rub out any sensitive info before uploading to play safe though)

Thanks for the suggestions. It’s a day early but tomorrow I will be occupied so I went ahead and tried some of the things you suggested. I tried shutting down the computer and the drobo did not go into standby.

I then powered off the drobo (unplugged) waited around 30 min then powered it back on while unplugged (to the USB). I have included a link to a video of what happened. Around min 3:30 I plug it back in to the computer then at the end pan over to the dashboard (which now doesn’t see the Drobo at all).

Further thoughts would be greatly appreciated.

thanks for the video,

right up to about the 4minutes mark it looks like it boots up and does things ok, (with top red)
then at about 4m 15s the top bay (after connecting the standby drobo to computer) shows a solid red (which is probably just due to capacity again… (can i check if your 2TB drive in the top slot?)

then at about 4m 40s when it starts flashing, those look like the rebuilding lights to me (yellow and green, and the lights are definitely looking a lighter shade than the deep red that was shown earlier.)

with this in mind, i really do think it just needs to do a full rebuild, and if you can, i would try to let it continue in this way, without any interruptions if possible for the rest of the week, say at least 6 days if you can.

and then, if it does not work after that, there are some other things we can try too if you wish

Hi, since your reply on the 6th I have left my drobo to do its thing and it continues to flash orange(yellow) and green. Its been a bit over 2 weeks (I had been letting it run yellow/green since the day before I posted, the 2nd) and its still blinking.

You mentioned some other options? Hopefully not ones that involve data loss (I have 90% of it backed up but I’d really really prefer not to lose that 10%).
Thanks.

thanks for the update,
it looks like even with about 16 days it is still not completing…

if you can wait 1 more day, and then if it still does not work, you could try putting the drobo into a readonly mode, which may help to stabalist things a bit to be able to copy off some data. (usually it is for reboot loops though may help here too), for example as mentioned here:
http://www.drobospace.com/forums/showthread.php?tid=143618

in case it does not let you, then you may need to shutdown the drobo (trying first via dashboard if it lets you, and also after shutting down the computer).

  • and then with power all Off and cables unplugged, to remove your diskpack drives from your drobo (remembering the order for later)
  • and then to try powering up the empty drobo and computer and dashboard, and trying to enable the readonly mode.
  • and then to shutdown the drobo via dashboard
  • and with drobo powered Off, to remove all cables from the drobo, and to put your diskpack drives back into the drobo where they were before.
  • and then to try powering up the drobo again (which i believe should still be in readonly mode)…

… please remember that if in read only mode, (which dashboard should be able to help verify), the drobo may look like it is doing something but it should just be in read only mode. (if during bootup though, it appears to hang on the blue let lights as they fill up from 1 to 10, please do allow it extra time though)

how are things now?

Thank you for the suggestion. That seems to have gotten me access to my drobo again. by the time I got to the end of your instructions it gave me all green lights, and blue lights but drobodashboard and windows couldn’t see the drobo so I shutdown my computer (effectively powering down the drobo?) then restarted and now I can access my drobo, albeit in RO mode. Would it be safe, do you think, to put it back in to RW mode?

Thx!

ah that is great news (from the accessing the data in read only)

i honestly think the best thing to do right now (if you can still actually access the data) would be to start copying it onto somewhere else while it is accessible.

once you have successfully copied your data (which may admittedly take a fair amount of time), then i think you may need to identify a good set of drives and to set up the drobo from scratch again (essentially like restarting and resetting the drobo, but only using a set of drives known to be good) - but you would not lose anything but some time, by trying to take the drobo out of readonly mode… but please, only try that after you copy your accessible data :slight_smile:

Thanks for all your help. I am in the process of copying things to my server but that will take… forever. I am a bit worried though as one of the drives has gone “red” (bad I assume)(but this is why I got a drobo in the first place so its kosher) so I will check it once I have copied everything.

Question though. I keep trying to find the largest supported drive for Gen2 Drobos and can’t seem to find it anywhere. I think I found somewhere before that 3tb drives should work which I can confirm, and I have used 4tb drives no problem. I figure if I am going to have to replace a drive that I should go ahead and “future proof” (proof is relative I know) things by getting a larger drive but I don’t know if the Drobo Gen2 can take 5,6,8tb drives?

Can you (or anyone) confirm compatibility of drives larger than 4tb?

Thanks!!!

My set up: Drobo Gen 2 Firewire: WD RED 5TB / WD RED 4TB / WD GREEN 2TB / WD RED 2TB
I have successful used a 4 and 5 TB hard drive in a Drobo Gen 2 (Firewire). HOWEVER: I had one of the bays empty and put in a WD 2 TB Green drive. The drobo didn’t see it (I know the drive is good since it was just in my Drobo Gen 1). I let the drobo run over night, but in the morning, the WD Green still can’t be seen. Therefore, I decided to do a little cleaning. I disconnected my drobo, so I can blow out the dust inside. My WD Red 5 TB hard drive doesn’t slide out! I have pushed the side tab multiple times (sliding the drive in and out) but it will only slide out about 1/4 of a inch then gets stuck. I don’t want to damage the drive. So I pushed it back in. Blew the dust out of the remaining 3 bays. Put in back all drives and started up again. All drives (including the WD Green) are running with green lights, and Drobo Dashboard can see the drobo. However…What am I going to do with that WD RED 5TB that doesn’t want to slide out???[hr]

I have the same Drobo Gen 2 Firewire. With four 2 TB hard drives, I have seen it work for over a week when the machine is less than half full (4 of 10 blue lights). Sometimes, I would replace a drive with a newer drive (like a WD RED), and would wait for a week before the data protection sequence is done. Therefore, with a Drobo that is just about full, I would expect to wait longer. BTW: I suggest you set up a method of backing up your Drobo, so that if Drobo dies, you don’t loose your data. My drobo is on a Mac, and TimeMachine is always backing up this Drobo. I also have another software (ChronoSync) that copies the file to another hard drive on my network in the middle of the night. It gives me peace of mine knowing I have the files since I know that the drobo days are number and reading this forum makes me worry with all the number of people with problems with their drobos.

btw ticzon1 already knows this thread, but there are some gen2 posts here by users with larger drives:
http://www.drobospace.com/forums/showthread.php?tid=147422

however, im think the officially tested drives are 4TB, and a max 16TB volume on that model, and there are some important caveats like certain firmware requirements or settings regarding the type of 4k sector advanced format drives, for example mentioned here
https://myproducts.drobo.com/article/AA-01199
and also here:
https://myproducts.drobo.com/article/AA-01124

(for ticzon1, just linking to your main thread about a stuck drive)
http://www.drobospace.com/forums/showthread.php?tid=147742