Drobo

2nd Gen Drobo in endless reboot

Greetings, I have a 2nd Gen Drobo that was populated with 4 drives totaling 7Tb. The Drobo showed that it was over 70 percent full so I decided I was going to replace the smallest drive in the cluster with a larger on. All drives in question are Seagate. So I did the swap and the Drobo started rebuilding and showed only 54 percent. All was right. The rebuild took about 36 hours and all lights were green. The next day there was a red light on the drive that I had just inserted and the other remaining drive were engaged in another rebuild. OK, so I purchase a new HD in anticipation of the completion of the next rebuild. The next day I came home to the same three flashing green and yellow lights and the one red. Drobodashboard stated that there was 7 hours remaining in the build. The next day (21hours later) the same lights are flashing and there are dozens of errors showing on my screen that the drive was improperly ejected. (Mac OS 10.10.5). Come to find out the Drobo was rebooting every 5 minutes.

Machine boots and shuts-down fine with no drives. I have updated the firmware. No change. I have tried every known combinations of drives with no luck including inserting a new blank drive. I have a back-up of all the important data. What is left that is not backed up is one folder with numerous .dmg files. I could format the discs and restore the main set of files, but I want to try to get that one set of files off before trying that extreme an option. However, the machine will not stay online for more than 2-3 minutes. Are there any known cures for this problem?!

hi wombat, sorry to hear you got some problems.

from the first part of info, it looks like you had about 4.5tb of data on the drobo? if that is the case, then i think the rebuilds would have probably needed at least 4 days to properly complete, as 36 hours sounds very quick to me but i might be mistaken.

can i check if you saw the drobo actually rebooting often? (its just that sometimes during a rebuild, it can become unavailable to ehe system, and it may have been coming back and going away from the systems perspective, rather then the reboot loop?)

i think its good that your drobo is booting up fine without drives (and hopefully dashboard see it like that too), but one thing you could try it to power all off, and to put your drives back in still while off, and then once you boot up the computer and dashboard see it, you could try to put the drobo into read only mode with some commands here, which might help it to remain up at least long enough for you copy your dmg files?
http://www.drobospace.com/forums/showthread.php?tid=142744

Yes I see the drive rebooting. It happens after about 3-5 minutes. All lights turn red and then I get the “Disc Improperly Ejected” error on the screen. I did see the posting that talked about putting it into read-only mode. However, the key combination was for PC only. I tried other similar keys on my Mac but they did not work. I was told to try that while the drives were out, shut it down, and reinstall the drives and reboot. I will attempt that tonight.

What about the power supply? There are other resources that imply that the power supply might be bad. Maybe the new drive exceeded the available wattage? Have you heard anything about that?

UPDATE - Success! Whether it was the read-only or a combination of that and the firmware update, the Drobo is now stable and rebuilding. Can’t thank you enough for the suggestion. Now I am going to update the backup and will scrap the whole set and start over with a new set of drives once the rebuild is complete.

ah thats cool news, am happy to hear its ok again now :slight_smile:
(btw yes i did hear about some possible wattage issues and it may play a greater part with future sata drives, but thankfully not that much of a problem so far)

you see, you can do anything when you put your mind to it, and in this particular battle of the reboots, you showed the skills of a true combat-wombat :smiley: heheh

So I was able to update my backup, but as soon as I took it out of Read-only the reboots started again. I will be scraping the remaining drives on this set and I have four new WD Reds. Am I going to have the same problem with a new set of drives? The rebuild never completed and Dashboard never showed an estimated time of completion. Everything was stable while in Read-Only, but I would hate to install the new drives and continue to have the same problem if it comes from the drives drawing too much power. I would not be able to return the drives and I would be forced to purchase a new RAID system. I have made sure that I have the firmware and dashboard up to date so I guess it is time to cross my fingers and pray. That is why they call it plug and pray right?

hi, it probably was mainly due to the old disk pack having errors, but what you could do is to power everything off, and to look at your drobo psu for wattage information,
(and maybe carefully also the underside of the drobo while empty, to see any usage info there too)
and then to add up the max wattage use of those red drive models, and that should be a good indicator if it can take it.

i was able to access some info recently that i posted for another user here http://www.drobospace.com/forums/showthread.php?tid=145217

Greetings,
After installing all new drives, I had to reset the Drobo then it went into formatting and configuration. I copied everything back from the backups but now there are so many corrupted files that they are useless. This was my media drive and I have checked the backup and the files are fine. It is the copies on the new Drobo that are all whacked out. I just used finder to copy the files back. Should I use Disk Utility or Carbon Copy Cloner to restore the files? The drive that is the source is one of those new Seagate 8Tb drives which are extremely slow to write but faster to read. Almost every file is corrupted. M4v’s, .JPEGS, .AVI. Nearly killed myself until I realized the original files are fine. (We are talking 15 years of photos) I just need to figure out how to transfer them back to the Drobo intact. Any suggestions?

hi, that last post sounded a bit worrying here too, until you mentioned that your originals are fine.

i think its good to keep the original source drive unmodified for now and to try some more tests using copies of data only… i say this because if the drobo has been reset, and reformatted, then as far as i know it should be blank, and it may be something else causing the issues.

you could try some disk utility checks or disk warrior to make sure the volumes were formatted ok,
but i think it would be good to try copying some images onto it in different ways as main test:

  • eg from your internal mac disk to the drobo
    (do the images both look ok when viewed from mac disk or drobo?)

  • copying from your non-drobo source 8tb to the drobo

  • and from 8tb source to your internal mac

  • and also, plus all of the above whilst using a different/new cable, (firewire/usb)
    (and if possible a different connection method such as usb instead of firewire or vice versa)

if you can, try to use a different image with each copy/paste test (in case the image gets cached somehow) - it doesnt need to be an image but usually an image will be easier to spot corruptions on.
(im hoping that it is a connection/cable issue, as that has been seen in the past)

I performed a disk check and it did find problems and fixed them. I then reformatted the drives and tried copying individual files. I have not tried different transfer methods (USB vs FW) but I have copied several different file types both to the drobo and then to my desktop as well as directly to my desktop from the backup. The jpegs all transferred fine and were readable, but the M4v movie file to the Drobo was still corrupted. I am wondering whether the Intellipower controller on these new WD Red drives has something to do with this problem? Seems that varies the rotational speed depending on conditions. The Data Robotics website lists WD Red as a tested compatible drive, but I am not sure if they have tested it on Gen2 products. The old discs were all Seagate Barracuda drives.

hmm ok, thanks for trying those tests,
if you get a chance with the festive season and all, to try usb vs fireware i think it will be a good thing to try, especially if your original mkv source file works fine without any corruptions.

(it might be worth rechecking the mkv source, just in case, as i would have thought that image files would have been corrupted plus other files too if a cable was causing it, but its a bit puzzling if its only the mkv)