Drobo

2nd drive failed during rebuild

I’ve had my Drobo S for over 7 years and had no problems until now. I had 2-2-1-2-2 TB drives and replaced the 1TB with a 2TB. During the rebuild process drive 2 failed. It gave a warning that too many drives have been removed. I have dual disk redundancy with the maximum size it would let me make (16TB?) and I used Truecrypt to encrypt and mount the whole drive. Luckily I back up my family pictures and movies every few months to an off-site NAS at my parents house, but it would be nice to get back the few months I’ve lost.

Is it possible to bypass the rebuild process and read the data off the 3 remaining drives?

I’ve tried:

  1. putting the 1TB back in.
  2. buying a new 2TB drive and put it in drive 2.
  3. putting the new rebuilding 2TB back in.
    All 3 give the same error about too many drives have been removed…

Thanks for any help you can give!

Now I’m worried if I get a 2nd new 2TB drive, one of the remaining 3 good drives could fail during the rebuild! Is there any way to bypass the rebuild and get my data from the 3 good drives before it tries to rebuild?