2 TB Drobo Mini Compatible Drives?

I had 4 x 1TB drives in my Drobo mini and one failed. Since I was due for extra space soon, I ordered a 2 TB drive to replace it. The exact model is a Seagate 2 TB Barracuda (ST2000LM015). When I put the drive in, it worked for several hours but then it was red and marked as failed the next day. I made sure that this wasn’t a defective drive bay by moving one of the remaining 1 TB disks around and that confirmed the problem was with the disk. I initially thought I had received a defective one but I got the replacement from Amazon yesterday and same thing happened: the drive worked fine for a few hours but then went to “failed”.

This makes me think that there’s an incompatibility with my current setup. I think I can probably return the ST2000LM015 and request a different model but I’m having a hard time finding a detailed list of compatible 2 TB drives. After googling, I found this announcement of a bundled Drobo Mini with 4 Samsung Spinpoint M9T 2TB drives which makes me think that this drive would be a safe bet.

Does anyone have any recommendations of 2 TB drives for the Drobo Mini? Can anyone confirm that there could be an incompatibility with the ST2000LM015 drives?


hi, it may be that if a particular drive was working ok that it would be also bundled, though can i check that the drive did fail not just with a solid red light, but also with the usual flashing / blinking red light?
(it probably was the flashing light in the end, though just wanted to check)

it may be possibly that your drobo mini was not using the latest firmware for it, can i check which version you are using?
(in case you are using an older version, it is usually best to do a backup before upgrading firmware, just to play safe if you can, especially if you do not have any backups)

it may also be worth trying to run some tools on that failed drive (or if you still have the 2nd one), hooked up to another device like an external usb drive caddy or something similar if you have it, though since your drive bay still worked ok with another drive, it may be something bad about that drive that the drobo detected, and in this case, possibly on both occasions.

I don’t have the drive anymore so I don’t remember for sure but I do remember that the Drobo Dashboard was telling me that the drive was “failed”.

I’m running firmware 3.5.2 [7.179.86336] and the Drobo Dashboard says this is the most recent version.

Unfortunately, I don’t have an external enclosure that I could use to run some tests.

Since I had to return the drive, I won’t be able to do a lot more to determine if the drive or the model was bad. I will be receiving a ST2000LM003 on Friday and I’m hoping that it proves to work well in the Drobo Mini.

Thanks the the reply.

You should be good with the ST2000LM003

I pulled four of them the portable backup plus external drives (for some reason they were cheaper in the enclosure than naked) and I have had zero issues with the drives themselves.

(the whole mini has started unmounting randomly, and I think it might be “eating” TB cables, but no individual drive problems)

Thanks for the info.

I got the ST2000LM003 yesterday and was converting my Aperture Library to Photos which is fairly disk intensive and the disk was still green this morning. Not to jinx it but it does look like my problem was that the ST2000LM015 had some incompatibility with the Drobo Mini.

thanks for the info, that seems to be the latest firmware available like dashboard mentioned, and it must have been something with the ST2000LM015 drive.

its good to hear the ST2000LM003 has been ok, and for rpassavant, i think some manufacturers of other products (such as enclosures) might get a cheaper deal in bulk, to be able to sell the finished, enclosed product with enough value added, and profit) - also good for people who just need a bare drive (almost said boar drive) :slight_smile: but yes it is sometimes counter intuitive but that is probably the only way to maintain the higher, baseline price for a bare drive.

if your mini is unmounting, would you be able to try with usb for a while, just to see if that makes a difference?