Drobo

2 Drobo 5Cs Ejecting Randomly After 4.1.1 Firmware Mac

Hey everyone -

I have 2 Drobo 5Cs that are both randomly ejecting after updating the Drobo firmware to 4.1.1 recently. One is connected to a 2013 Mac Pro and the other is connected to a 2013 iMac. One is running Mojave and the other High Sierra. No issues before the update. Anyone else experiencing this?

After troubleshooting some it could be related to Power Nap (Article Id: AA-01732). Around the same time I updated this firmware I also enabled Power Nap. I will post an update soon.

I just upgraded Mac to High Sierra 10.13.6 and within a few hour Drobo 5C registered a hard drive failure in Bay #4. Replaced that drive with a new larger drive and with 48 hours a different drive failed in Bay #1. The odds of two different drives failing within this short time frame are remote. Drobo firmware and dashboard are the latest. Submitted support request to Drobo Support and hoping to hear something soon.

I’ve the same problem. Don’t know if it’s the update causing it, but yesterday my 5Dt randomly ejects.
Seems like it only happens when I’m copying onto the Drobo.

All I’ve tried so far is plug the Thunderbolt cable to another port, and to eject the hard drives, reset the Drobo and put in the drives again. Didn’t help.

Maybe it’s the cable, but since others have experienced the same, I guess not.

Have anyone found a solution?

Thanks!

Also having issues with the 5C and specifically the iMac Pro. I have four 5C units. The ones attached to older Mac Mini servers are fine, I have zero issues with them. I have opened support cases with Drobo, only to have them marked as resolved as they blame data corruption. I have swapped all of the 5C units around, I have swapped all of the hard drives around. I have swapped computers around. The issue seems to be specifically with the USB3 chipset and/or driver in the iMac Pro. I have reset and updated firmware and Drobo Dashboard on all of them several times, nothing fixes the issue. I have to move the two 5C units off the iMacs to older Minis in order to make them work properly. There is a major flaw in Drobo’s driver specifically to the iMac Pro. When copying files or backing up, really any activity that actually reads or writes to the disks, causes the Drobo to unmount and remount, or completely crash the Drobo.

When the Drobo is being used, the system constantly emails me that the Drobo is full and I need to add or replace a disk. They only have 2% usage.

The Drobo is running extremely low on available space. If the Drobo has an empty bay add a drive of equal or higher capacity. If all bays are in use, find the bay with the solid Red light and replace that drive with a higher capacity drive.
Free Space : 17.84 TB (98 %)
Total : 18.03 TB
Message sent from:
Device Name: Drobo
Device Type: Drobo 5C
Host Name: iMac-Pro.local
Host Time: 20/Feb/2019 05:46:38 AM
Host IP Address(es):

I have had the two most recent units for six months. They have been doing this since new.

I have a 5C bought a couple of months ago, running latest firmware (4.1.2) and dashboard (3.4.2) connected directly to a Mac mini (2018) running macOS Mojave 10.14.5 with the Drobo supplied USB cable.

I cannot essentially use the Drobo in any “sleep” configuration. It will disconnect on waking up the mini. Power Nap is disabled. And if you reboot the mini without first unmounting it and shutting it down, it will also disconnect several seconds/couple of minutes after rebooting macOS (if you are copying a file to it or from it, it will give an error and stop the operation). Once it disconnected after cold boot of both Mini and Drobo…

On a side note: My Mini also shows weird behaviour when using heavily the USB3 ports - the Apple original Magic Mouse on BT would lag when the USB3 ports are used (USB C ports don’t give me the same issue and the Magic Mouse works perfectly fine on an iMac late 2013 that also has USB3 ports, but of course in a completely different design/shielding). I ended up using a USB mouse…

So for me there is a fault both at Apple and Drobo. Support of USB3 from Apple doesn’t seem perfect at all, and Drobo is having issues in fixing what Apple seems to break or change constantly (like Wifi in the past years :smiley: ).

I had a regular HDD in a cheap enclosure and it would go to sleep and wake up correctly on this Mini.
But the Drobo is a lot more complex machine, essentially a Linux box with a complex flexible RAID configuration, pretending to be a USB3 drive, and clearly there are message conflicts between the Drobo and the Mini/macOS, that have the Drobo behave weirdly.

BTW, when the Drobo goes to sleep, sometimes after 1 min it wakes up again and then after a few more seconds it sleeps again. Somehow the Mini sends a message that the Drobo recognises as “wake up” or the Drobo for some reason decides to wake up on its own, to do nothing…(no HDD activity heard).

So now I simply disabled all sleep functions on the Mini, as well as on the Drobo (disk spin down is off), and unmount it and turn it off at the end of the day. It works ok because it is not a work disk but more of a back up.

I think the Drobo hardware is ok, it is a plain software issue. If Apple or Drobo are at fault, hard to say.
I files with Drobo Support a ticket since the very beginning. They have been prompt in reply and it has been escalated (as per email from 2 days ago). The issue seems to be common enough to get attention and to take quite some time for them to figure out what is going on.

PS: I tried the Drobo 5C on an older MacBook Pro without the Drobo Dashboard software and same behaviour. So it seems the Drobo Dashboard software has no fault of its own. I don’t know how it behaves on a Windows machine as I don’t have one to try it on.
PS2: all my data is backed up in any case elsewhere (as it should be!!!) but so far no data loss.

Thanks for the info. I have an update too. The newest DroboDashboard came out, and it no longer supports El Capitan, so I updated on of my host Minis to see if the new Dashboard/Driver/Firmware made any difference. Bingo, that Mini started acting weird and the Drobos started crashing just like all of my other systems. So, as an experiment, I downgraded all of my host Minis to El Capitan, DroboDashboard V.3.2.1, and firmware 4.1.2 and all seems well. Doing hourly TimeMachine backups from many remote machines is reliable again.

It seems then that Mojave is creating all the trouble. They have changed something and Drobo’s software doesn’t work well. But Mojave has been release almost a year ago: still not a chance for Drobo to fix this?

Mojave has been updated to 10.14.5, would you Shutdown the Drobo via Drobo Dashboard > Tools, update to 10.14.5 and see if this resolves the issue. You may also try disabling Power Nap. Last, ensure you are on the latest firmware and dashboard for Drobo:

https://www.drobo.com/docs/

I did (I always update to the latest version of macOS mostly for update in security patches), and it made no change.
Power Nap is disabled since first seeing the issues and getting my Drobo 5C back in Feb. as per documentation and support’s advice.

is there a hub or adapter being used, are you using the same cable that shipped with Drobo? Did you have a support ticket I could reference, if so would you upload diagnostic file to server.

The Drobo is attached directly via the supplied cable to the Mac mini (2018 model).
The case ID is #190411-80295 and Brad D (Sr. Drobo Support Agent) wrote me on May 13th that the case had been sent to the development team and that they would be in touch ASAP.
I haven’t heard anything since.

I was able to find your support case and I case see the agent has followed up with engineering. It does appear to be talking longer than normal for a reply, we have followed with engineering for an update.

1 Like