1st Gen Drobo U/S - can I transfer pack to 2nd Gen Drobo?

My first generation Drobo (Bought in 2008) (USB) with 4 1TB drives has given up. It was being used on Mac OS X 10.8.2 latterly.

I tried hooking up another external 12V power supply of suitable capacity but just keeps rebooting. I also Reset it (with disks removed), but still will not boot up with drives removed.

According to my notes I am using firmware 1.3.8 on the Drobo.

Can I get hold of a 2nd gen drobo and put my existing disk pack in it and expect it to just work?

I did look at the knowledge base but was totally confused by it.

Many thanks in anticipation.


you can migrate a disk pack from a drobo 1 to a drobo v2

Thanks for the confirmation, I just wanted to be sure that there were no caveats before purchasing a 2nd Gen Drobo for this.

Best wishes.

This suggests there are no issues with that migration, such minimum firmware versions, and etc.

Thanks, fingers crossed it works!

braeside, you ask a good question. The gating items for moving the Drobo v1 to a v2, both 4 bay , may only entail which firmware level they reside on. I cannot say for certain. I found some other helpful links:


If you were attempting to move between releases, meaning a Drobo v1/2 up to Drobo S or FS or Pro or 5D/N, then there are multiple caveats. But in your case, while nothing explicitly says it will work, I would try it.
I assume that you are out of warranty.
Do either power supply give you the same results?

Update here:

My 1st gen unit is way out of warranty, so I had nothing to lose. I opened the unit up and cleaned a bit of dust out of it, found a lithium rechargeable battery in there, wondered if that may be the problem. While I had it in bits just for fun I put the power on again, and it worked! So I am not sure what caused it to start working again.

In order to test that it was not the power supply, I actually cannibalised the original PSU by cutting the lead so that I could use the lead on a big variable high current supply I have here. Needless to say it wasn’t the PSU, so I now have to patch the lead back on to the old PSU again.

Because I had assumed my unit was terminally dead, I had ordered a 2nd Gen 4 Bay Drobo, was fortunate to get one new on eBay, as I think they are no longer manufactured.

At least the 2nd Gen should be a bit faster as it has FireWire, the old USB 1st Gen was much too slow.

I’ll let you know how the migration goes. At least I can back up some stuff from the old disk pack now that the old Drobo is going again.

The 4 bay Drobo is still listed on their product page, and available for purchase so I have assumed it is still “in production”, or at least not officially end of life’d.

Given the rather steep price tag of the 5D, it would make sense that Drobo would keep the 4 bay in the lineup. They need some sort of “entry level DAS model”, and $800 isn’t entry level in my neck of the woods.

Congrats on the fix. My experience is that things tend to spontaneously break when I take them apart. They don’t usually spontaneously fix themselves :). Entropy usually works!

Neil, oddly I can’t find any new Drobo 4 bay for sale on the main Drobo.com site, just the drobocare for that product. Another UK online store that was advertising them, when I ordered one, advised me they had no stock and was end of stock entirely. So I think that they are no more in reality.

I still see 4-bay Drobos on sale, but availability seems to be limited. California Fry’s Electronics stores seem to have special (refurb?) units at a discount.

Thanks Brandon, I am in the UK however. Fortunately eBay has a couple of new ones available still.

and amazon:


Missed that one with a search yesterday! - Oh well, I have got one coming and will flog my old Drobo once it arrives.

interestingly, i looked on amazon and the 5n is showing a lot cheaper then the 5d?
is there any particular reason for that?

“Drobo DRDS4A31 5N 5 Bay Desktop NAS Storage Device” search vs:
“Drobo DRDR5A31 5D 5 Bay Desktop Direct Attached Storage Enclosure”

The 5N is indeed a couple hundred cheaper than the 5D, even at list price. Why? I’m honestly not sure. Can Thunderbolt chipsets actually cost that much?

i’d suggest maybe the 5D is simply faster - ,more memory / faster processor? there’s no point building an INCREDIByl fast 5N if its limited to the GbE cable… just build one capable of saturatin GbE

The 5N has a quad-core CPU and a gig of memory; I doubt the 5D has anything more advanced. If anything, the 5D doesn’t need to run an OS like the 5N - just BeyondRAID.

I’m nitpicking here, I know, but BeyondRAID doesn’t run on bare metal, too. Older Drobos used VXWorks real-time OS, probably that’s still the case with the recent ones.

No, that’s true. I just couldn’t recall the name of the underlying RTOS. :slight_smile:

hmm thats interesting… i would have thought that a networked/sharing device would have needed more cpu or processing/transfer speeds, in order to give multiple users/streams high transfers, but maybe i misunderstood :slight_smile:

im not 100% sure what the minimum transfer speed requirement is for streaming high quality files, or blue ray etc, but if thunderbolt was to add so much more cost to the unit, if a more generic connection such as ethernet port or usb could have done the job, then it seems to make more sense to remove it and reduce the base cost of the unit?