Drobo

10.6 Snow Leopard

Has the Drobo V2 been verified under Snow Leopard 10.6? I want to avoid corrupting my data. Thanks.

Don’t know if it was verified, but it’s running just fine on my machine.

And mine!

Works on my 10.6. (latest Build)
Latest Drobo Dashboard and FW
1.5.1 & 1.3.3