Drobo

1.3.7 Firmware Update

I installed the 1.3.7 Firmware Update and it seems to go along fine except when it asks to reboot the Drobo it un-mounts and shuts down, but does not reboot. I read the FAQ on this problem and rebooted the Mac Mini and it then restarted.

But when I go into Drobo Dashboard, it still says the firmware is 1.3.6…

I have gone thru this process 2x now with the same result. No reboot of Drobo, having to restart computer and the reporting of old firmware.

Something definitely fishy there : when I updated to 1.3.7, the DashBoard did show 1.3.7, not 1.3.6.

is it my imagination, or were you having trouble copying data to in the thread i reply to about a minute ago?

i would suspect if there is something faulty in your interface - if you are unable to write data reliably to drobo - i would NOT try and write a firmware to drobo!!!

i imagine that the firmware update is two stages:

  1. copy the firmware to drobo

  2. reboot so the firmware can be applied and run

i can only imagine that it appears to copy, but when it reboots drobo realises the firmware is corrupted as a result of an error during copy so does not complete the update process and continues to boot from its known good/old firmware.

thats pure speculation but is the most likely scenario i can think of

Yup that is me. I have contacted support through their web site and hopefully will be able to get it figured out. Have tried 5x to apply the firmware update but no reboot from the drobo. After rebooting the computer however, the drobo shows up fine and files are all there and accessible. Very strange behaviour. Thanks for the replies.

Have you tried the firmware update via USB?

I am now connected via USB and have once again attempted to apply the new firmware. I have reached the “reboot the Drobo” stage and the Drobo has now un-mounted and currently waiting to see if it re-mounts on its own. I’ve heard it can take some time to apply the firmware, so I’ll see what happens.

Should take 2-3 minutes.

I honestly would recommend the repair disk first connected via USB, because if you having disconnect issues and Error 36 on FW you are causing data corruption. You want to fix that first.

If that doesn’t work, do the firmware update via USB when there are NO drives in the drobo.

The new firmware will not apply under USB either. Exact same behaviour as when connected via FW800. After selecting reboot it is like it goes to sleep, all lights off except for the power light, which is orange and can be only seen by removing the front cover. It just stays that way until you reboot the Mac.

Still reporting 1.3.6.[hr]

I will give that a try Jennifer. Interesting suggestion.[hr]
OK, I gave your suggestion a try, and in the end it worked. The new firmware is showing up in dashboard now. But when I applied it with the drives removed, it did the same thing. Waited 10 minutes and no reboot, just sitting in standby mode. I removed the power from the Drobo, and re-inserted the hard drives and re-attached the FW800 cable and reconnected the power. The Drobo found all drives and initialized. Dashboard then reported 1.3.7 firmware. So it seems to have been successful. Maybe somehow this firmware will fix my other issues.

Time will tell. Thank you for all the helpful suggestions

I’m having the same issue of the firmware update not applying. My Drobo does in fact reboot after copying the firmware over but when it comes back up dashboard still shows it running firmware 1.3.6

I, too, am having this problem. The Drobo shuts down, but then does not reboot. If I restart it either by disconnecting or by restarting the computer, it tells me there is a firmware update and we repeat the cycle. The firmware still shows as 1.3.6. I’m connected via firewire 800 and am on 10.6.4 and dashboard 1.7.3.

Please open a support case.

Same here. I have applied the firmware update several times but the version remains the old one each time.

I too have the same problem - even with reboot firmware remains at previous version. I’ve run disk repair and it reported nothing wrong with the Drobo.

I’ll open a support case.

Same here. No firmware update success from 1.3.6 to 1.3.7.

First ever problem, my first post here, and my reason for registering. Glad to know I’m not alone.

Support case being opened.

Please do the following:

  1. Download the latest firmware for your Drobo at www.drobo.com/support/updates
  2. Open the DMG or ZIP file and drag (or extract) the TDZ file to your desktop.
  3. Rename the .tdz to .zip.
  4. Open the ZIP file.
  5. Do one of the following:
  • If you have a 1st generation Drobo, which only connects via USB, drag the file that ends with “rev1.tdf” to your desktop.
  • If you have a 2nd generation Drobo, which can connect via USB or FireWire, drag the file that ends with “rev2.tdf” to your desktop.
  • If you have a DroboPro, DroboS or DroboElite, drag the file that ends with “.tdf” to your desktop.
  1. Open Drobo Dashboard: Advanced Controls -> Tools.
  2. Hold your Ctrl key down on your keyboard and click the “Check For Updates” button in the bottom left-hand corner of the window.
  3. Navigate to the Desktop and find the “rev1.tdf,” “rev2.tdf” or “.tdf” file. Double-click to open it.
  4. Complete or stop any data transfers and then click OK.
  5. Be patient while your Drobo device’s firmware is being updated.
  6. Once complete, click on the “Reboot Drobo Now” button.
  7. Go into Drobo Dashboard: Advanced Controls -> Tools. In the bottom right-hand corner of the window under “Installed Versions," verify that the firmware has been updated to the current version.

If you drobo is shutting down after clicking on “yes” to reboot, Please open a support case. Please note in case which firmware you are currently on, dashboard version, your Mac OS version and if you are on FW or USB.

  1. The link is incorrect.

  2. Should read “Hold your control key…”

This did not work for me. My Drobo (v2) shut down, as it did with the automatic updates, and then did not reboot. When I manually restarted it, it immediately offered to install the 1.3.7 update; my version remains at 1.3.6

for windows… i think its called “option” on macs

No actually it’s control key on both OS’s.

Sorry just copied and pasted didn’t notice the typos. Fixing now.

@mike7 please open a support case.